Page MenuHome

Remembering values
Closed, InvalidPublic

Description

System Information
Operating system: win10
Graphics card: 970 gtx

Blender Version
Broken: 2.80, ae977d13f8e9
Worked: 2.79

Short description of error
Blender do not remember values for spin, bevel, inserts, extrude, etc.


Also if set in pref default value for it do not affect, if i push spin angle will be 0 not 90

Exact steps for others to reproduce the error

  1. Do spin, bevel, inserts, extrude, etc
  2. Adjust value at last operation panel
  3. Do spin, bevel, inserts, extrude, etc

Details

Type
Bug

Event Timeline

konstantin (miller) updated the task description. (Show Details)
Jacques Lucke (JacquesLucke) triaged this task as Needs Information from User priority.

I'm not fully sure what you expect. Don't you adjust these settings interactively?

Could you pick one specific operator and show how behaves differently from what you expect?

Thanks.

I'm not fully sure what you expect. Don't you adjust these settings interactively?
Could you pick one specific operator and show how behaves differently from what you expect?
Thanks.

So when you bevel and then adjust value in the panel its remembering it and applies to the next bevel

https://i.gyazo.com/18af08d3e3b7e308f9bb9596f8e6281a.mp4

https://i.gyazo.com/b49a88ab6adebe1f994dc0cb4ab07e2c.mp4

Could you please be more specific about what you are doing in these videos exactly? And which Blender version did you use in them?

I can reproduce the issue shown in the first video using Redo Last operator. Did you use that operator as well?
However, I don't know how to reproduce what you showed in the second video.

im using 2.79b
this one video splitted in two.

  1. select edge
  2. ctrl+b
  3. adjust value amount in the panel
  4. select another edge

5 ctrl+b

Jacques Lucke (JacquesLucke) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Mar 4 2019, 12:55 PM
William Reynish (billreynish) closed this task as Invalid.

This has been mentioned before, but given that these are interactive operators, it doesn’t really work if it ‘remembers’ the the previous amount settings. The amount is set by how much you move the mouse cursor.

That said, it’s useful to be able to record and re-play operations again, but that is much more of a feature request.

For now, you can use Repeat History, which lets you repeat previous operators with the same settings.

Pablo said its a bug.
But u still can adjust amount with mouse.
Example i have set up my tool (insert "i") for specific amount. and then do a different action, how i can do insert with same amount

You can use Repeat History to repeat the same command again with the same settings.

The issue with using the previous settings automatically for these things, is that it conflicts with the interactive operators which depend on the mouse cursor dragging.

It works only if i do smth continuously, but if i what for example insert specific amount then bevel then inset again with than specific amount
why you just remove it, it was perfect in 2.79

I answered it multiple times. The reason is because these tools are interactive, based on cursor position. If the interaction is to be consistent, it cannot ‘remember’ the past value.

Also, Repeat History can go back many steps.

In the future it could be interesting to have macro recording-type functionality for storing and repeating operators.

But it work in 2.79 pretty nice
I can not understand this.
just make as in 2.79

It's not so nice if the value starts off being offset by however much you last used the operator.

Think of doing a rotation for example:

Let's say you rotate an object 45 degrees. Then you select a different object and want to rotate it 15 degrees. If rotate would start with a 45 degree offset, that would be extremely confusing, because the user then constantly has to counter the last amount rotated.

Re-applying operators again with the same settings is very useful, but there's a conflict when using interactive tools that depend on the mouse cursor.

If you have any useful ideas on how to solve the conflict that would be a useful contribution.

whoa, rotate is not on the list, as move and scale.
Actually extrude is not on the list too.
So there are only three tools Spin, Bevel, Insert

Move, Rotate, Scale, Extrude, Inset Faces, Bevel are all interactive, based on cursor position. As such there is no real difference in this case.