Page MenuHome

2.8 | Empty Images have washed out colors in viewport render
Closed, ResolvedPublicKNOWN ISSUE

Description

System Information
Operating system: win7 64
Graphics card: gtx 1080ti

Blender Version
Broken: blender-2.80.0-git.1df6a98b176f-windows64 2019/03/05

Worked: Tried a few random versions, might have never worked in 2.8

Short description of error
Empty Images have washed out colors when rendered using Viewport Render. As far as I see it doesn't affect materials.

Exact steps for others to reproduce the error
Drag and drop any image into the viewport. Go to view> Viewport Render

Event Timeline

Karlo (kpavicic) updated the task description. (Show Details)
William Reynish (billreynish) lowered the priority of this task from 90 to 30.Mar 5 2019, 4:06 PM

Can you please provide a demo blend file that shows this? Thanks.

Blend:


Image showcasing the problem in the attached blend file:

In the viewport, reference images aren't affected by color management, but in the rendered output they are.

@Brecht Van Lommel (brecht) It's unclear to me what is the correct or expected behaviour here. In the end this doesn't seem like it's super critical, as reference images are meant for references, not output.

William Reynish (billreynish) raised the priority of this task from 30 to 90.Mar 5 2019, 5:34 PM
Brecht Van Lommel (brecht) lowered the priority of this task from 90 to Low.Mar 5 2019, 6:08 PM

I think there's perhaps a double color transform going on. It won't always match exactly due to use color management settings, but should be closer than this.

Richard Antalik (ISS) changed the subtype of this task from "Report" to "Known Issue".
Clément Foucault (fclem) closed this task as Resolved.Jun 22 2020, 4:05 PM
Clément Foucault (fclem) claimed this task.

This was fixed by the color management refactor in 2.83. The colors do not match 100% (because of different pipeline) but they are not washed out anymore.