Page MenuHome

Constant crashes file save, save as, new workspace, etc. perhaps related to grease pencil
Closed, ResolvedPublic

Description

System Information
Operating system: 10.14.3 (18D109)
Graphics card: nVidia 750m

Blender Version
Broken: 2.80, 90afe3918110

Short description of error
Clicking File -> Save, or File -> Save As, creating a new workspace (2d Animation) after creating a grease pencil object on a default scene crashes every time.

Exact steps for others to reproduce the error

  1. Open blender to default settings
  2. Shift & A -> Grease Pencil ("Blank")
  3. Tab -> Draw mode
  4. Draw anything in the viewport
  5. Save the file (File -> Save)

5a. Or, save as the file (File -> Save as)
5b. Or, create a new file (File -> New)
5c. Or, add a new 2D Animation workspace

I can't attach a .blend because I can't save one :(

Crashes at the end of the recording:

Details

Type
Bug

Event Timeline

Nick (nickmade) updated the task description. (Show Details)
Nick (nickmade) updated the task description. (Show Details)

Cant redo:

  • OS: Linux 4.20.13-arch1-1-ARCH
  • REV: b2889c7cf122a5bc6b028470c3c3800637e780ab
  • GPU: GeForce GTX 1080
Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

Can you see if this still happens with the latest blender beta?

Nick (nickmade) closed this task as Resolved.Mar 6 2019, 1:44 PM
Nick (nickmade) claimed this task.

The latest (blender-2.80-ecd086ac3224-OSX-10.9-x86_64) looks like it works. Thanks, guys!