Page MenuHome

Material Ouptut selection broken
Closed, ResolvedPublic

Description

System Information
Operating system: Win 10
Graphics card: GTX 1080 TI

Blender Version
2.80, 0ba143a1d675, 2019-03-08

When two Material Outputs per shader are used, blender doesn't change to the designated.
Rendering the right material output works but changing the shader refreshes only when related material output is selected.

For example:
One Output is set to eevee and the other is set to cycles.
Switching between cycles and eevee renderer loads the right tree.

When parameters from the cycles tree are changed while rendering in cycles,
there are no changes made when eevee material output is selected.

Possible fix: just select the designated material output automatically when the renderer is changed.

Details

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Confirmed, Medium priority.Mar 8 2019, 12:23 PM

Confirmed, checking...

Seems like we are allowing a (shader) output node to become the current output (NODE_DO_OUTPUT) regardless of the target this node specifies.
Would suggest to check the current render engine and only allow the output node to be come the current output if it matches the target?

Had a go at the first steps in D4482, further discussion there...

Brecht Van Lommel (brecht) raised the priority of this task from Confirmed, Medium to Confirmed, High.Apr 1 2019, 1:41 PM
Philipp Oeser (lichtwerk) closed this task as Resolved.Apr 1 2019, 3:24 PM
Philipp Oeser (lichtwerk) claimed this task.

Actually, the issue seems resolved already...
So we now do get updates when rendering in cycles if eevee material output is selected, but changes are made in nodes that are connected to the 'designated' cycles output node...

[unsure why I didnt notice this, since the change must have been made around the time when this report was made...]
[to doublecheck I will git bisect when this started to work...]

EDIT: rB89fa6a7a063 was the commit that made this work.

No need to workaround by actually selecting the designated output, cycles will pick up updates from the tree where the most appropriate output is connected.

To my understanding, we can close this one [@Daniel Paul (DaPaulus): make sure to comment again/reopen if issues persist...]