Page MenuHome

Blender EeveE Frame Render Light Flicker
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 Pro
Graphics card: GTX 1070

Blender Version
Broken: 2.80, 8df5e0eb66f7, blender2.8, 2019-03-04 18:40
(example: 2.79b release)
(example: 2.80, edbf15d3c044, blender2.8, 2018-11-28, as found on the splash screen)

  • Renders in Eevee have flickering frames ,where the light is flat and shadows don't show, like only a few frames at random points have flat shading , left is beginning of animation with the flicker ,and the right one is the next frame , it seems that starts and ends are always flickering , but somtimes even frames in the middle of the animation flicker**

Details

Type
Bug

Event Timeline

Please provide a blend file with an example of the bug. The nodes are collapsed in that screenshot so it's hard to guess the settings of the math node and the normal map node

Alex (AnubisMaster) added a comment.EditedMar 10 2019, 6:39 PM

Its just a separate RGB with the Green Subtracted (to flip it basically) , and then all merged back together , nothing fancy , just a DirectX Normal fix solution i found online https://blender.stackexchange.com/questions/100017/directx-and-opengl-normal-maps

THAT is beside the point tho ,because if i use DirectX normals or Normal Map node ,its the same Bug

I can't replicate it with my own models and normal maps, some of which are directX, but all of them look perfect. That's why we need an example blend file with textures attached, to discard factors like the gamma and the kind of normal texture itself, the UV map used as tangent in the Normal map node for model with multiple UV maps, to help you if it's not a bug but just the setup, and ultimately to know if it's just a bug on that happens with one particular gpu driver or a more general bug.

Sure thing ,thing here is the file i've removed the useless and just kept the essentials , but with the error still there ,i also put the textures used in case it didn't Pack all

I can't replicate it with my own models and normal maps, some of which are directX, but all of them look perfect. That's why we need an example blend file with textures attached, to discard factors like the gamma and the kind of normal texture itself, the UV map used as tangent in the Normal map node for model with multiple UV maps, to help you if it's not a bug but just the setup, and ultimately to know if it's just a bug on that happens with one particular gpu driver or a more general bug.

Alex (AnubisMaster) renamed this task from Blender EeveE Oily Normal Maps , Unreal Engine , Substance Painter to Blender EeveE Frame Render Light Flicker .

Thank you for the file. After seeing your model now I can definitely find it on mine, but to a lesser extent. It seems those flipped normal are areas where the combined normals go above 90 degrees away from the camera. I imported the model to unreal and it definitely happens there too, but less glossy, more similar to the rest of the material. It would be nice for Blender to do it that way but I'm not sure the developers would consider that a bug instead of a known Eevee limitation.

I also notice that you edited the task to be about the other bug, so I guess that settles that

yes i changed it to an actual bug because i noticed the reason why that OILY look is caused is because the Normal Map has Dark artifacts on the Seams , so since its got bad artifacts its bound to happen , the only way for now i see it can be fixed is running the normal map through Substance Painter

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

I can reproduce the flickering with the attached file on my end. However I had to remove the GP object or else the render would be pitch black.

Are the file still relevant to the current bug reported there and does the flicker go away for you if you delete any GP objects in the scene?

(This might be related to T62279)

A fix for similar issues has been commited rBe28f0f179d2a. It should be in tomorrows build. Please check if this solves it for you.

Bastien Montagne (mont29) closed this task as Resolved.
Bastien Montagne (mont29) claimed this task.

Assuming this has been solved then…