Page MenuHome

Grid always shows in orthographic view even when turned off in Overlays
Closed, InvalidPublic

Description

System Information
Operating system: Win Pro 64 bit
Graphics card: GTX 1050

Blender Version
Broken: 2.80.0 40412499433e

Short description of error
Turning off the grid in Overlays doesn't turn off the grid when in orthographic view. However, the grid will not show if the master Overlays toggle is turned off.

Exact steps for others to reproduce the error
Enter an orthographic view. Uncheck Grid in the Overlays options. Grid still shows.

Details

Type
Bug

Event Timeline

Antonio Vazquez (antoniov) triaged this task as Confirmed, Medium priority.

I can reproduce it on windows 10.

The grid keeps visible when you are in Front/Side/top view in orotgraphic mode. If you move the viewport to other positions, the grid is hidden.

Example:

Not sure, but I think this one is for @Clément Foucault (fclem)

PS: Not sure if this is by design.

PS: Not sure if this is by design.

Why would a toggle that doesn't work be by design?

Campbell Barton (campbellbarton) closed this task as Invalid.

This is working as intended, see tooltip.

So there's no way to disable the grid in orthographic view unless you hide ALL overlays. Broken by design. Gee thanks.

A note in a tooltip doesn't make this any less broken.