Page MenuHome

New added objects will not appear in Local View
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 Pro 64
Graphics card: GeForce GTX 1080 Ti

Blender Version
Broken: blender-2.80-6fd11a21f5c5-win64
Worked: 2.79

Short description of error
New added objects will be placed outside of local view, when working in local view mode.
The user is forced to exit the local view, reselect the objects and go back to local view. Really unproductive.
Imagine what this mean if you are working with dozen of models...

Exact steps for others to reproduce the error

  1. Start new scene.
  2. Create any mesh object (cube e.g.)
  3. Select the cube and switch to local mode. (Press / -key on numpad or use menu View->Local View->Toggle Local View.)
  4. Add a another object inside local view.

-> New object is not visible in local view mode but exists in scene.

This issue sounds banal, but it's really ugly if you are modeling with a lot of objects.

In version 2.79 new added objects were always automatically added to local view. This is important and something logic.

Please reactivate this function!

Here is a video on youtube with additional infos:
https://youtu.be/opGClr9dSmY

Event Timeline

Can´t confirm. In todays build new created objects are added to local view.

Hi. Thank you for the response.I'm using todays build too.

I've prepared a video for this issue in my first post to explain what is actually happen, by showing you some examples.

Basically you are right, but there are some issues with the local view I explain in my video. So currently something is not round and should be definitely fixed.

Thank you
Chris

I watched your video and tried to reproduce it. I tried to add new objects to local view. It worked except of the torus.
The torus is the only mesh primitve which is not showing up in local view if you add it! This is a bug!

So I can confirm that if you add a torus to local view, its not added like the other primitves!

Have you tried the Extra Objects AddOn too?
Later in the video I show it with a single vertex object that comes with the extra objects AddOn that is an official build AddOn.

Here is the link to the video position to see it: https://youtu.be/opGClr9dSmY?t=180

Thank you
Chris

No I havn´t tried the extra objects AddOn. But I think you made the bug clear. The developers should have a look on adding objects to local view.
They should make it work, that adding all kind of objects and geometry plus from the extra objects AddOn should work in local view as expected.
I think they will solve the problem soon!

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.

I can confirm that the torus does not appear in local view when added.

I also noticed that if you select vertices in local view and add 'Hook to new object' (ctrl+h), the newly added empty will be outside of local view. In 2.79 it was inside of local view. Don't know if it deserves separate bug report.