Page MenuHome

Blender 2.79 file opening in Blender 2.8, does not respect dupli-group display type
Closed, ResolvedPublic

Description

System Information
Operating system: Ubuntu 18.04
Graphics card: GTX 1080

Blender Version
Broken: rBd7e7e9af026e5713de5299fed9b5de463a51f3bc

Short description of error
Opening Blender 2.79 files in Blender 2.8, does not respect dupli-group display type.

Exact steps for others to reproduce the error

  1. Open attached blend file in blender 2.79
  2. notice how the dupli-group is in bounds mode
  3. open the same file in blender 2.8
  4. notice how the dupli-collection is no longer in bounds mode.

This causes problems on large production scenes, especially with the viewport slowdown (T58188)

Event Timeline

Bastien Montagne (mont29) triaged this task as Confirmed, Medium priority.

Confirmed.

@Brecht Van Lommel (brecht) not sure whether this new behavior is expected, or if this slipped in during the whole group-to-collection complicated code work?