Page MenuHome

Closing files takes about 5 times longer
Closed, ResolvedPublic

Description

System Information
Win 10
1080 TI

Blender Version
2.80 6b39dc7672eb

Short description of error
Did some tests with loading times. File is about 600 MB
I noticed that closing the file takes about 5 times longer since 2 weeks or so.
(I update Blender daily)

OPEN FILE:

Old version (91a155833e59 / 2019-01-07)
15,30 Seconds

New version (6b39dc7672eb / 2019-03-12)
13,40 Seconds

CLOSING FILE:

Old version (91a155833e59 / 2019-01-07)
1,12 Seconds

New version (6b39dc7672eb / 2019-03-12)
5,04 Seconds

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

@Campbell Barton (campbellbarton) did some changes in that area, could be related.

Some questions though:

  • What do you mean by 'closing the file'? Saving and quitting Blender? Or just quitting Blender without saving anything?
  • If you are saving, did you check that the 'compressed' option is the same in both cases?
  • Otherwise, could just be the 'session recovery' .blend file written when closing Blender, if compression status on that one changed, that would explain the slow down… but looks like that file remain uncompressed for me.

Ctrl + N -> General

Compress file is deactivated in both cases.

That's what I thought too, that it could be the closing file,
but with ssd the autosave isn't even noticeable.
Feels like instant save while the file is below the write speed of the ssd (in this case 560MB/s)
I get a 1-second lag while autosave when i work with files about 1GB of size.
I think the quit file is saved the same way autosave file is saved.

@Daniel Paul (DaPaulus) does this happen for very simple file? eg, subdivide a cube 7 times, then duplicated in object mode 12 times (results in a 613mb file here).

Saving the quit.blend takes around a second for me.

If you can't redo this subdivided cubes, please upload a blend file that shows the problem.

I did a factory reset, now its gone. Quit time is back to one second.
Maybe some plugin could have caused the problem.
Can't reproduce the issue. Thanks anyway :)

Daniel Paul (DaPaulus) closed this task as Resolved.Mar 13 2019, 10:19 AM