Page MenuHome

Blender 2.79 vs 2.8 - Changing between solid and wireframe mode is slower
Closed, ResolvedPublic

Description

System Information
Operating system: Ubuntu 18.04
Graphics card: GTX 1080

Blender Version
Broken: 41cb5658803bf3b96f18e93c74c6af66ecdb1e83

Short description of error
Changing between solid and wireframe mode is slower.

Exact steps for others to reproduce the error
This is an example file, other production files are significantly worse.

  1. Open attached blend file in blender 2.79
  2. press z many times (blender 2.79 keymaps) to toggle back and forth
  3. feel how snappy it is
  4. switch to blender 2.8
  5. press z many times (blender 2.79 keymaps) to toggle back and forth
  6. notice how it lags.

Details

Type
Bug

Event Timeline

Jacques Lucke (JacquesLucke) closed this task as Archived.
Jacques Lucke (JacquesLucke) claimed this task.

That is not a bug. Maybe it can be optimized later, but this is outside of the scope of the bug tracker.

Also in this file there are more than 2.000.000.000 vertices. Blender is not really made for these vertex counts...

That is not a bug. Maybe it can be optimized later, but this is outside of the scope of the bug tracker.

That is fine, as long as its registered that it is slower.

Also in this file there are more than 2.000.000.000 vertices. Blender is not really made for these vertex counts...

I would like you to also reconsider other uses of Blender, especially for infrastructure visualization. Our scenes usually span between 5km square to 100km square, with heavily instanced trees. I am comparing performance between 2.79 and 2.8 on real world scenes and that i am then replicating it in test scenes so i can upload and help make blender even better.

2,000,000,000 vertices is a lot yes... but most if not all are instanced and out of view. 2 billion verts is not that much for a production scene, instanced trees (2000 trees at 100,000 per tree) hits this quite easily.

I would like to have this bug revisited. Whilst it may not be important to you, I have tried to work in a production scene for a day, and this was a deal breaker. Having to wait 3 seconds every time I want to switch between the modes breaks the flow of the artist.

This may not be viable for a blender 2.80 release but 2.81 or later should have it looked at.

Brecht Van Lommel (brecht) lowered the priority of this task from Confirmed, Medium to Needs Information from User.

Is this still an issue in latest builds? I believe this should be faster now, but not sure if this is entirely solved.

Just built it, seems like it is slightly slower but still an acceptable speed.

Thanks for all your help!