Page MenuHome

Linked armature issue
Closed, ArchivedPublic

Description

System Information
Operating system: Win10
Graphics card: Gtx 980

Blender Version
Broken: latest daily build 2.8 , march 14
Worked: 2.79

Short description of error
Linking an armature into a scene and making a proxy of it lead to a dependency cycle + translation offset
Exact steps for others to reproduce the error

  • Link the main collection of the attached file in a blank scene, it contains one armature (one bone) parented to an empty object.

  • In the outliner, Scene mode, right click the Collection1 sublevel > "Link to Scene"
  • Select the Armature1 and make a proxy of it
  • The bone is shifted in translation, and a dependency cycle is reported in the console

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.
Bastien Montagne (mont29) closed this task as Archived.Mar 17 2019, 4:16 PM

Thanks for the report, but that is not really a bug, proxies are a very limited system designed to work in a specific way, and by linking the collection to the scene you break that expected behavior (since you actually instantiate into the scene all the collection's objects, and your armature is child of a rig empty...).

Proxies are designed to work from an instantiated linked collection (i.e. what you get when linking the collection, the empty which instantiate said collection).

Thanks for the feedback, but sorry I don't understand. How are we supposed to fix this then?
In Blender 2.79 we can link the group (which is now the "collection") containing the same objects hierarchy, and make a proxy of the armature without any issues.

Alright, I think I got it... We have to create the proxy right on the linked collection, without instancing it like we did in Blender 2.79. Fine :)

Well, to be precise, 'linking' a collection into a scene is not the same thing as 'instancing' it. The 2.7x way of using groups is same as instancing a collection in 2.8 (i.e. adding an empty in the scene, which 'duplicates' said collection), and that’s what is supported by proxies.

Linking a collection into a scene (technically, a view layer) in 2.8 is closer to defining that collection as being a sort of custom layer (in the sense of scene's layers of 2.7x). It actually instantiates all of that collection's objects, and not the collection itself…

Ah yes, terminology is terribly confusing nowadays :(