Page MenuHome

NodeCustomGroup does not see its input in Eevee, works in Cycles
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 8 64 bit
Graphics card:

Blender Version
Broken: blender-2.80.0-git.388ff003e28b-windows64
Worked:

Short description of error
I am building a 'LayerStack' node that would allow you to stack up layers and paint in them as you do, e.g., in Photoshop. The whole thing only makes sense in Eevee but, unfortunately, it does not work.

Exact steps for others to reproduce the error

  1. Open the file, open the text editor and the shader editor.
  2. Run the script, you will see the 'LayerStack' node added to the ShaderEditor window.
  3. Click the plus button to add a new layer to the node.
  4. Connect the RGB input into the 'LayerStack' node, output the 'LayerStack' node into the 'BaseColor' of the principled shader.
  5. Switch to 3d Viewport Object Mode.
  6. Check that the custom node group does work in Cycles.
  7. Switch to Eevee, the object is grey.

Comment: I know that this is a separate bug report but, just FYI, there also seems to be a problem with custom Socket types. I have registered

class MySocketClass(bpy.types.NodeSocketColor):
   def __init__(self):
      instructions()
   def draw(params):
      instructions()
   def draw_color(params):
      instructions()

when this socket is instantiated in the shader editor, FPS of Blender becomes twice as little. Also, when I instantiate MySocketClass(), Cycles preview would constantly rerender (like each frame), as if MySocketClass were sending some strange kind of updates to it. If I close the shader editor, the problem goes away (not the main bug, just the constant updates bug). I do post another bug report for that but maybe you find it useful to know because looks like there's a mess with subclasses of Node-related types...

Details

Type
Bug

Event Timeline

Sergey (sergey1994_m) renamed this task from node custom group does not see its input in Eevee, works in Cycles to NodeCustomGroup does not see its input in Eevee, works in Cycles.
Sergey (sergey1994_m) closed this task as Invalid.
Sergey (sergey1994_m) reopened this task as Open.

Custom nodes aren't supported in EEVE currently, D4370 needs to land for that first

thanks a lot for clicking. is there hope that this will be implemented by release? you know, with custom nodes and eevee, you could make another substance painter out of that. should I freeze this bug report?

Brecht Van Lommel (brecht) closed this task as Resolved.
Brecht Van Lommel (brecht) claimed this task.

Fixed by rB9e152f919f2f: Python API: add Python-defined node groups for shaders and compositing., though ShadeNodeCustomGroup has to be used now. For custom socket issue you could report a separate bug.

awesome! I have built this night, and it works just. awesome!! so many thanks. Please, could you take a look at the bug reports on the socket error and failure in the insert_link() function? T62671 and T62670.