Page MenuHome

force fields parameters effects particles when the force field strength is 0.
Closed, ArchivedPublic

Description

System Information
Operating system: Linux-4.20.0-042000-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: Mesa DRI Intel(R) UHD Graphics 630 (Coffeelake 3x8 GT2) Intel Open Source Technology Center 4.5 (Core Profile) Mesa 18.2.2

Blender Version
Broken: version: 2.80 (sub 48), branch: blender2.7, commit date: 2019-03-14 22:54, hash: rB35b78d9807c4
Worked: (optional)

Short description of error
tested with turbulent forces:
flow, size and noise parameters effect particle system when strength is set to 0.

  • maybe a feature not a bug?

i expected strength 0 would turn off the whole effect.

Exact steps for others to reproduce the error
add a particle system to the mesh,
add a force field - fe: turbulent
set noise 10, strength 0 and play.
set the flow and size too

Details

Type
Bug

Event Timeline

Stephen Swaney (stiv) triaged this task as Needs Information from User priority.

Got a .blend for us?

Philipp Oeser (lichtwerk) closed this task as Archived.
Philipp Oeser (lichtwerk) claimed this task.

This is expected behaviour.

Noise is added on top of the strength.

See the manual https://docs.blender.org/manual/en/dev/physics/force_fields/introduction.html#common-field-settings

Adds noise to the strength of the force

Also see code here

strength += wind_func(rng, noise_factor);

While this might seem counter-intuitive, this is working as expected and not a bug, closing...