Page MenuHome

Comment with no line number problem
Closed, ResolvedPublic

Description

There appears to be a problem with the PO file

'LC_MESSAGES/editors/3dview/grease_pencil/stroke_edit.po'

Where the comment is duplicated and one of it (top line) doesn't have a linenumber reference at the end:

#: ../../manual/editors/3dview/grease_pencil/stroke_edit.rst
#: ../../manual/editors/3dview/grease_pencil/stroke_edit.rst:76
msgid "Menu"
msgstr "Trình Đơn -- Menu"

This is causing sphinx to abort with error upon write (dump_po) in the file

  • '.local/lib/python3.6/site-packages/sphinx_intl/catalog.py'
  • '.local/lib/python3.6/site-packages/babel/messages/pofile.py'

Exception occurred:

File ".local/lib/python3.6/site-packages/babel/messages/pofile.py", line 592, in write_po
  for filename, lineno in sorted(message.locations):

TypeError: '<' not supported between instances of 'int' and 'NoneType'

The problem is caused by the line

sorted(message.locations)

since it was expecting to see that there is a line number (int) and not 'None', due to the missing number. This is happening with every language sets.

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) removed Bastien Montagne (mont29) as the assignee of this task.

This is the manual, not blender's i18n…

Hi all,

I'm new to Blender development and was hoping to contribute to Blender in some way. I was wondering if this bug still needed a fix.

Best,
echoi7

Aaron Carlisle (Blendify) closed this task as Resolved.
Aaron Carlisle (Blendify) claimed this task.

Im guessing this has fixed itself? If not please re open this task.