Page MenuHome

Under or No Utilization of AMD Asus Vega RX 64 GPU and Double Listing
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Graphics card: AMD Asus Vega RX 64

Blender Version
Broken: all 2.8 so far

Short description of error
I'm having a Asus Vega RX 64 GPU, and have noticed nearly no utilization of it in either Eevee or Cycles when checked via Windows Task Manager

I'm having a Intel 4670k CPU and obviously wanted to utilitze my GPU for my renders in 2.8 but so far have not seen signs of proper utilization of my GPU. I have set my settings properly. See:

https://cdn.discordapp.com/attachments/506056426410606603/557763227140751373/unknown.png
https://cdn.discordapp.com/attachments/506056426410606603/557764491790647296/unknown.png

Yet in my task manager, I hardly see more than 5-6% utilization of my GPU. Even after applying the fix (for a related issue of Double Listing) mentioned here (There has been some performance gains, overall but task manager shows CPU utilization going up to 80%+ and RAM usage above 70 to 80% of 8GB):
https://devtalk.blender.org/t/cycles-detecting-two-of-a-single-graphics-processor/5810

I have a NVme SSD, so I'm sure that storage is not a bottleneck either. I'm having 19.2.1 version of AMD drivers, which is the stable release.

I assume, that I'm using both my GPU (5-6% of overall capacity) and CPU (80%+) with my current settings

Details

Type
Bug

Event Timeline

@Ahmad Bilal (SomeAB) I think the Task Manager only shows 3D usage in the overview. I had two switch one of the sub graphs to COMPUTE_2 to see the actual load. For me 3D peaks at the beginning at 15% and COMPUTE_2 is continuosly above 80%.

Ahmad Bilal (SomeAB) added a comment.EditedMar 20 2019, 8:51 PM

It seems you are right on that issue mostly, I just did a test render and checked performance in Task Manager and GPU Tweak 2, and this attached screenshot (Image1) shows the results. But then, I rendered the same scene with CPU option unticked in the user preferences, and the checked both Task Manager and GPU Tweak 2.

Result (same sample scene) in Cycles (blender-2.80-798d2cadc307-win64) :

  1. GPU (first listing only) ticked and CPU ticked and device set to GPU Compute : time taken 42 seconds approx, GPU load in GPU Tweak 2: GPU Clock above 95%, GPU Memory Clock above 90%, GPU RAM usage around 3.5GB out of 8GB, CPU usage in Task Manager stable around 66%, System RAM usage around 50%
  1. GPU (first listing only) ticked and device set to GPU Compute: time taken 42 seconds approx, GPU load in GPU Tweak 2: GPU Clock above 95%, GPU Memory Clock above 90%, GPU RAM usage around 3.5GB out of 8GB, CPU usage in Task Manager between 8% to a peak of 38-40%, System RAM usage around 50%
  1. CPU ticked and device set to CPU: time taken 8 min 25 sec approx, GPU load (insignificant or around the idle performance), CPU Utilization: stable around 60% but using only 2.0x GHz out of the base speed (without overclocking) of 3.40 GHz listed for my CPU, system RAM usage is suprisingly still stable around 50%

But this is only half of the issue. The second half was the double listing of AMD GPU. And only after un-ticking the second listing has my performance really went up (see the devtalk thread above). I feel that needs to be fixed in case of certain AMD GPUs.

Image1:
https://drive.google.com/open?id=1wW1qeLOn1FSu2-OYE3fr3JYET_kf75S9

The peak in 2. is most likely happening while the scene is prepared for rendering. For 1. and 2. having about the same render time is probably due to 3. performing bad. During 42 seconds 3. is able to render roughly 8% of the scene, which should save about 3.5s. This could be lost to the overhead of rendering on CPU and GPU simultaneously.

Do you see different numbers when rendering in 2.79?

Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.

When rendering with CPU only, the tiles sizes might be too big for all cores to be used. That's something we want to improve still, so you don't have to tweak tile size for best performance, but it's outside the scope of the bug tracker.

Regarding the double detection of the GPU, it would help to get more info on that. Can you run blender --debug-cycles from the command line and attach the output here?


@matc (matc) : I will download the 2.79 and test the same scene in it, and post the numbers shortly, to help out. Btw, although I'm unaware of the techinical details, but I kept a rough eye on my task manager, and the peak was hit for few seconds inbetween and towards the end as well. This is not a big deal now (for me), since my render times have increased significantly (ever since I unticked the second GPU listing mainly). But just letting you know, in order to help with future optimizations.

@Brecht Van Lommel (brecht) : I have attached the screenshot of that output, as well as clinfo log (someone suggested it to me on blender discord).

clinfo shows the same platform and GPU twice, so I think there is something wrong with your AMD driver installation. Maybe there are remnants from an older driver install, or a bug in the AMD driver.

I only could find this, which suggested installing newer drivers but you already have the latest. Fully uninstalling and reinstalling the drivers may help.
https://community.amd.com/thread/219774

We could try to work around this on our side as well, though in doing so we also risk excluding some GPUs that should be exposed.

I'm pretty sure that I have clean drivers(though I can check very deeply as well), as I had to do a clean back up few months ago, as some bug on AMD side was causing a annoying error (Basically AMD control panel was showing that updates were available, when you were already on latest drivers). I know how troublesome GPU drivers can get sometimes (thus I'm on a stable version, while a optional version is available).

Double listing is okay, as it is ticked by default (even in 2.79). The issue is the performance drop.

Speaking of 2.79, I installed it but could not properly get my test file to render in it (as I have never worked in 2.79 UI/UX). But I did see (as I mention above) a double listing of my GPU by default. On my part, I'm satisfied, but I fear that this bug (if it is so) .. can cause other AMD GPU users problems. And as you can see on the devtalk.blender forum, I'm not the only person having this issue.

Brecht Van Lommel (brecht) closed this task as Archived.Apr 7 2019, 3:20 AM
Brecht Van Lommel (brecht) claimed this task.

Closing this as not a bug in Blender, but in the graphics driver installation.

I rather not try to fix this as it risks breaking other valid setups.