Page MenuHome

Pack into Blend then Unpack into files breaks linked objects/groups
Closed, ArchivedPublic

Description

System Information
Operating system: Multiple networked computers running Windows 10
Graphics card: Various

Blender Version
Broken: 2.97
Worked: (optional)

Short description of error

If you have a scene with locally linked objects or groups, save it to a different folder, then press File > External Data > Pack All Into Blend, then press File > External Data > Unpack into file (this is a way of moving textures from one project to another) any objects or groups that are linked with local paths no longer show up : the links are broken.

Exact steps for others to reproduce the error

Start with a file in folder A (which I'll be calling Group.blend)
Create a new file and save it as Scene.blend in folder A
Edit Scene.blend and link an object/group in Group.blend
Press Save As and save it as SceneB.blend to another folder (folder B)
Open up SceneB and press File > External Data > Pack All Into Blend
press File > External Data > Unpack into file
Save and re-open SceneB.blend
The object/group from Group.blend is no longer visible in the scene, as the link is broken.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Cannot reproduce (tried in 2.8 and 2.79)

Afaics packing should not affect libraries at all [operates on images, fonts, sounds...]

If I follow your steps, all I am getting for pack/unpack is:
No new files have been packed
No packed files to unpack

To progess with this report we need your .blend files, please post them here, so we can have another look...

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

Closing due to lack of information to investigate the issue, we can reopen if .blend files are provided to reproduce.