Page MenuHome

floating windows on Cycles and Region Overlap
Closed, ResolvedPublic

Description

System Information
OS: Arch Linux x86_64
Kernel: 5.0.2-arch1-1-ARCH
Uptime: 1 day, 3 hours, 25 mins
Packages: 2070 (pacman)
Shell: bash 5.0.2
Resolution: 1920x1080, 1920x1080, 1920x1080
DE: Xfce
WM: Xfwm4
WM Theme: Microcurve
Theme: Xfce-dusk [GTK2], Breeze [GTK3]
Icons: Arc [GTK2], breeze [GTK3]
Terminal: xfce4-terminal
Terminal Font: Source Code Pro 10
CPU: AMD Ryzen 7 2700X (8) @ 3.200GHz
GPU: NVIDIA GeForce GTX 1050 Ti
Memory: 6554MiB / 64420MiB


Blender Version
Broken: cycles on 2.80 - 2019-03-16 - cc5bdf029324

Short description of error
When the window is floating and moved to another monitor, the render preview results distorted.

Exact steps for others to reproduce the error

  1. Enable "Region Overlap" on the settings
  2. Set Cycles as render engine
  3. Float the 3D view to another monitor (doesn't happen on a single monitor)
  4. Enter render view
  5. Zoom in and out. Closer to the object happens more frequently. Or also move around the objects if not in camera view.

Here a video briefly showing what happens:
https://youtu.be/OvkfDktpZ-Y

Event Timeline

Francesco Yoshi Gobbo (FraYoshi) updated the task description. (Show Details)

I don't know how to remove the mention.. sorry for it.

Brecht Van Lommel (brecht) lowered the priority of this task from 90 to 50.

The mention is fine, it's just linking to the commit that matches your build.

Aaron Carlisle (Blendify) closed this task as Resolved.Dec 28 2019, 7:41 PM
Aaron Carlisle (Blendify) claimed this task.

This is an expected lag between rendering the geometry and the overlays on top. Improvements have been made since this bug report.