Page MenuHome

Screw modifier bug: Cycles render preview different from final render result
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10 Pro 64
Graphics card: GeForce GTX 1080 Ti

Blender Version
Broken: blender-2.80-1ae6aaad43ad-win64 (Same issue in blender-2.79-d7cecc2ba3f6-win64)
Worked: -

Short description of error
See my screenshot / Attached scene file.

  1. Viewport render preview looks nice.
  2. On the left hand you see the final render result.
  3. Only solution to see a correct final render is to apply the screw modifier in the stack of the "Bottle cap" object.

Further note: I've observed same problems with screw modifier and reflections in the same scene.

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file.

  1. Open the file.
  2. Right hand viewport: Switch to "rendered view" mode. Cycles begin to render.
  3. Press F12 now, to see the final render on the left hand side.

-> Compare the results. The Bottle glass in the final render on left hand is wrong. Only solution for a correct final rendering is to apply the screw modifier in the stack of the "Bottle cap" object.

Details

Type
Bug

Event Timeline

William Reynish (billreynish) closed this task as Invalid.

This doesn't appear to be a bug. Your Screw Modifier Render Steps are simply lower than the regular Steps.

No. That's not the reason. I've already checked it. I know the screw modifier well.

Even if you increase the render steps there's no difference.

Thank you

Plase wait with tests. I'll check my origin file and give feedback.

This doesn't appear to be a bug. Your Screw Modifier Render Steps are simply lower than the regular Steps.

You're right.

I'm so sorry. I was sure it was a bug. I've completey overlooked this. (Maybe too tired......) Actually I know Blender...

Excuse my post. I'll close this issue.