Page MenuHome

Camera's background image invisible in wireframe mode
Open, Confirmed, MediumPublic

Description

System Information
Operating system: Ubuntu 18.04 Linux-4.15.0-46-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 390.116

Blender Version
Broken: version: 2.80 (sub 51), branch: blender2.7, commit date: 2019-03-22 21:47, hash: rBfaecac0b5e14
Worked: 2.79b

Short description of error
Camera's background image invisible in wireframe mode

Exact steps for others to reproduce the error

  1. Open new file.
  2. Go to camera view
  3. Put background image in the camera (drag&drop image while in camera view)
  4. Toggle wireframe and any outer shading mode. You will not see the image in wireframe mode.

Details

Differential Revisions
D4638: Camera Background Images
Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.Mar 23 2019, 7:28 PM

Also not visible when Xray mode is enabled, or transparent objects are shown.
It does work when Depth test is set to Front. Seems to be a depth test issue.

In the forward rendering the issue is related to the checker depth image, this seems to break the depth test when drawing the background picture.
In the deferred renderer this can be fixed by setting the depth test to GL_LEQUAL. But for the forward renderer we cannot trust the depth image to be valid.

My proposal would be to move this feature to the overlay engine (where IMO it should belong) as the pixels of the camera picture interfere with the alpha pixels of the workbench/eevee. In Blender 2.79 Background pictures and alpha was also not really working, but wireframe was.