Page MenuHome

Blender 2.80 - Incorrect rendering of subsurface in eevee after resizing the viewport region
Closed, ResolvedPublic

Description

System Information
OS: Ubuntu 18.04.2 LTS
Kernel: Linux 4.15.0-46-generic
Graphics card: AMD RX 480
driver: amdgpu-pro - 18.40-676022
resolution: 1366x768

Blender Version
Broken:
Blender 2.80
Date: 2019-03-24 22:08
Hash:72ede30d0f97
Branch: blender2.7

Short description of error
Resizing the viewport region produces an incorrect rendering of a material with subsurface scattering in Eevee, see below:
https://streamable.com/kzlwt
( the issue still occurs when the region is resized vertically too )

Exact steps for others to reproduce the error
1 - File > New > General
2 - Enable "Subsurface Scattering" in the Render tab of the Properties
3 - Select "Shading" tab
3 - In the material, pick a value greater than zero in the Subsurface input
4 - Resize the viewport region vertically or horizontally

Details

Type
Bug

Event Timeline

I would suggest you to try with the latest AMD drivers (18.50) you can download here:
https://www.amd.com/en/support/graphics/radeon-400-series/radeon-rx-400-series/radeon-rx-480

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Mar 26 2019, 2:56 PM

I can't reproduce this with the open source drivers.
Try the latest drivers and report back.

I installed the latest version of AMD gpupro driver: amdgpu-pro 18.50-725072, and I am still able to reproduce the error.

Sebastian Parborg (zeddb) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Mar 28 2019, 11:20 AM
Marco (nacioss) triaged this task as Needs Information from User priority.Fri, May 10, 2:49 PM

blender-2.80-427c75e4c20b and AMD gpu pro 19.10 driver installed, I'm unable to reproduce the bug anymore!

Marco (nacioss) closed this task as Resolved.Mon, May 13, 6:19 PM
Marco (nacioss) claimed this task.

Great to hear!