Page MenuHome

gltf export with jpeg textures
Closed, InvalidPublic

Description

System Information
Operating system: gentoo linux
Graphics card:

Blender Version
Broken: 2.8
Worked: (optional)

Short description of error
With exporting jpeg textures them assigned as png images and dont founds
this is the file


If i manually change in gltf text file "png" to "jpg" all works fine

You may test on this site
https://www.creators3d.com/faq
This is my shader setup

Where i can attach ao texture?

Details

Type
Bug

Event Timeline

If I understood correctly, the issue was that the images had the wrong mime-type/file suffix referenced in the gltf-file. I wasn't able to reproduce the error with the zip-files attached. Any chance of seeing the actual .blend-file?

sorry,
this is my scene (2.8)
http://pasteall.org/blend/index.php?id=51463
and can you please describe me, where to connect AO texture and why my rough texture works only with my strange shader structure

Amon (UX3D-soares) added a comment.EditedApr 1 2019, 5:48 PM

Thanks for the scene. Unfortunately, I was not able to reproduce the bug with your file, as the packed image files got corretly converted & exported as png* and therefore worked without issues when loaded into a viewer. My advice would be to update your current blender version and try the gltf export again.

footnote*: Currently, all packed images in blender will be converted to png during the gltf-export-process.

As for your question regarding AO, I don't know how to correctly integrate your AO-texture into node tree, but you can try your luck here: https://blender.stackexchange.com/questions/ask. What I DO know is that AO is currently not supported in glTF 2.0.

very strange
i test with blender 2.8 linux build from builder.blender.org and it exports non packed jpegs fine
but bug happend with my own blender-2.8 build from git source
https://drive.google.com/file/d/1x5gdZe7J-YSNXUziQncj7TFfxoWbCFeY/view?usp=sharing
https://drive.google.com/file/d/1p06pmXRdwmZesSIljGhLrTtQCtN0lDGX/view?usp=sharing
now i cant understand where i fail to configure blender to build
can you check my cmake file, please?

Julien DUROURE (julien) closed this task as Invalid.Apr 2 2019, 10:45 AM

This issue tracker accepts only bugs from official builds (official release or from builder.blender.org).
For any building issue, please ask on IRC #blendercoders on freenode

Closing this issue