Page MenuHome

UI Value Slider, incorrect cursor position
Closed, ResolvedPublic

Description

System Information
Operating system: Darwin-18.2.0-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon Pro 455 OpenGL Engine ATI Technologies Inc. 4.1 ATI-2.4.10

Blender Version
Broken: version: 2.80 (sub 51), branch: blender2.7, commit date: 2019-03-24 22:08, hash: rB72ede30d0f97
Worked: 2.79b

Short description of error
After dragging, the cursor is in the wrong position relative to the Value Slider indicator.

Event Timeline

William Reynish (billreynish) triaged this task as Confirmed, Low priority.

Can confirm, although it's hardly a big issue. Marked as low priority.

Task done. It was reminiscent offsets from the old pill-shaped UI.

Not sure what I'm doing wrong, I can't see the issue in the current Blender version.
Can someone make a short .gif that shows the issue?

Maybe I'm just looking at the wrong thing...

@Jacques Lucke (JacquesLucke): In 2.79, the mouse cursor always ended up where the slider ends, when you let go. In 2.8, it is a little inaccurate. The patch makes it so it’s 100% accurate again.

William Reynish (billreynish) raised the priority of this task from Confirmed, Low to Needs Information from User.Apr 2 2019, 4:24 PM

@Victor Seiji Hariki (seijihariki) Hmm, now I can't seem to reproduce the issue. Can you provide more exact steps for a video that demonstrates the problem?

Try to set the value to 0, in this case there will be a maximum cursor offset, with 1 there is no offset.

blender-2.80.0-git20190402.17c15798c35f-x86_64

William Reynish (billreynish) lowered the priority of this task from Needs Information from User to Confirmed, Low.Apr 2 2019, 5:03 PM

@Yevgeny Makarov (jenkm) Ah yes, can reproduce now again.

@Jacques Lucke (JacquesLucke): Can you?