Page MenuHome

Camera lag with Auto Depth turned on
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 (1809)
Graphics card: GTX 1070

Blender Version
2.80, 532536bf52da, beta, 2019-03-27

Short description of error
I am experiencing a lag in camera movement while sculpting with activated Auto Depth. With Auto Depth active there is a lag by about one second until Blender reacts to my camera movements. With Auto Depth turned off the lag is gone. This behavior only occurres on denser meshes (about 2 million polys in this case).
I can reproduce the same lag on Windows with NVIDIA Graphis (GTX 1070) as on a Mac Pro with AMD Graphics (RX 580).

Here is also a screen capture to illustrate the problem.
https://www.dropbox.com/s/xajkvcg3xawheqw/blender_28_autodepth_lag.mp4?dl=0{F6892502}

Event Timeline

Not sure if this can be considered a bug.

With Auto Depth a bunch of extra things have to be done (drawing ZBuff etc.) which might eat some performance on highres geometry...
Would ask @Campbell Barton (campbellbarton) (maybe @Clément Foucault (fclem), @Brecht Van Lommel (brecht) as well?) if there is room for improvement here?

There is no lag with the same scene in 2.79 with or without Auto Depth. Also I notice much lower viewport performance (fps) in 2.80 compared to 2.79.

Let's first fix T60043: macOS viewport lagging and then see what the performance looks like for the various settings.

Brecht Van Lommel (brecht) changed the task status from Duplicate to Unknown Status.May 21 2019, 11:17 AM

Wait, I confused this with another report..

Brecht Van Lommel (brecht) lowered the priority of this task from 90 to 30.May 21 2019, 11:21 AM

To me this kind of excessive lagging definitely sounds like a bug.

@Oliver Harries (olyandros), there have been recent changes in drawing of the depth buffer, could you verify if it's still an issue?

Demeter Dzadik (Mets) changed the task status from Unknown Status to Unknown Status.May 30 2019, 6:41 PM
Demeter Dzadik (Mets) claimed this task.

Closing because no info in over a week. Feel free to reopen.

Daniel Paul (DaPaulus) changed the task status from Unknown Status to Unknown Status.Aug 29 2019, 2:01 PM

Unfortunately, this is still an issue, when eevee is used in a quite moderate scene with some shaders, the lag is clearly noticeable.
Deactivating auto depth feels much smoother, without any lag.

Still an issue here on Blender 2.81 beta from 2019-10-12. I'm glad I've found this task, I've disabled auto-depth and it is smooth as usual.

Windows 10 1803
Threadripper 1950X
Titan X(p), 431.86

Richard Antalik (ISS) closed this task as Resolved.Jan 2 2020, 1:55 AM

I have not been able to reproduce this issue. Even in 2.81a

Please try the latest daily build: https://builder.blender.org/download/

If the problem persists, please let us know so we can re-open the report. Don't forget to mention the specific version you tested again.