Page MenuHome

Selection working not as intended. You need to drag mouse rather than click when in Select Box, Select Circle and Select Lasso modes
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10, 64 bits
Graphics card: Nvidia Geforce GTX 1070 8 gb

Blender Version
Broken: cd92f8ea4626-windows64
Worked: 07f6be87a97e-windows64

Short description of error
Good day, dear Blender Developers! Sorry to bother you, but it seems that selection tools are working differently (and somewhat glitchy and inferior IMO) in the latest builds (checked it yesterday and today) now? For some reason, in the last two builds I cannot just click on a face, edge or vertices to select them when I'm using Select Box, Select Circle and Select Lasso (default hotkey W) tools respectively in Edit Mode and I cannot select mesh objects the way we used to in Object mode too. Now I have to always drag my mouse to start selecting elements, when I use those tools and I cannot just select elements with one click as I used to while in those modes in other builds, which made selection so much comfortable.

Only when I'm in Select mode I'm allowed to select objects and mesh elements with one click in latest build. I don't know if it's a bug or intentional, if it's intentional then this is way more inferior that it used to be before as it makes me tap W key all the time when I want to select by just clicking.

P.S. By the way I'm using left-click select as default I found the left-click transition to be more comfortable over the whole beta, I'm sorry =)).

Exact steps for others to reproduce the error
Open startup scene in build cd92f8ea4626-windows64 with left-click as default.

Start clicking on an object pressing W to switch the modes and notice the difference in how the selection works in different selection modes.

If it's not obvious or noticeable then run the build 07f6be87a97e-windows64 (March 25th) and observe the way selection tools work there, you will notice a stark difference (it used to be better in the earlier builds).

Details

Type
Bug

Event Timeline

I think I got what causes that, it's the user's custom hotkeys files (again, I had the similar problem with right-click context menu not popping up on right-clicking an object last time due to renaming a week ago) that migrates from version to version, probably there were renamings in selection commands again =(. It makes my custom hotkey files obsolete with every build, should it work like that? Will this happen in the stable version too? I'll probably have to remap everything from scratch now. I don't want to sound spoiled but that's a days work every time I migrate to a newer build, maybe something could be done to custom hotkey file management in preferences? =((

William Reynish (billreynish) closed this task as Invalid.

Yes, this is probably due to a recent change in the select operator.

@Chingiz Jumagulov (Krayzmond) Unfortunately, this will keep happening whenever someone changes the operator names or settings during the beta.

It should not be a days work as it only means changing one item in this case, but I can sympathise that it's annoying. Unfortunately I'm not sure there's a way around it.