Page MenuHome

Non-Object fcurve channels always selected in dopesheet (e.g. World and Shader Nodetree actions)
Closed, ResolvedPublic

Description

Blender Version
Broken: blender-2.80.0-git.9099305771ec
Worked: 2.79

Description of error
If world or a material's nodetree has an action with fcurves for animating its properties, if you try to select any other channel in the dopesheet you'll notice that the nodetree and world fcurves are also selected.
The fcurve keyframes are not always selected, but the fcurve itself.
They appear to be permanently selected, unless you deselect all in the left hand pane of the fcurve editor., but as soon as you click on any other fcurve channel in the dopesheet, they are selected again.
This creates a problem when you want to remove fcurves completely, as the nodetree/world fcurves also get deleted.
Currently I have to switch off the editability of these problematic fcurves so as to not accidentally delete them, which is very annoying.

Probably an issue with all non-object animation data embedded actions, besides just nodetree and world fcurves.

Details

Type
Bug

Event Timeline

Tom Wilson (hedgehog90) renamed this task from World and shader nodetree fcurve channels always selected in dopesheet to Non-Object fcurve channels always selected in dopesheet (e.g. World and Shader Nodetree actions).
Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

Can you provide a sample .blend file with strait forward steps to reproduce?

IE:

  1. Open .blend file
  2. Try to select channel A
  3. Notice it fails
Bastien Montagne (mont29) closed this task as Invalid.
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.

Sorry, forgot to follow up on this.
If I post an example and detailed steps tomorrow will you re-open or should I start a new bug report?

Post here and we'll reopen.

Tom Wilson (hedgehog90) changed the task status from Invalid to Resolved.Apr 18 2019, 1:28 PM

The issue appears to be resolved by blender-2.80.0-git.03bd024c077d