Page MenuHome

Is urllib3 missing from blender 2.79b x64 zip? Error when installing blender-cloud addon
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10 Pro x64
Graphics card: nvidia Tesla m60

Blender Version
Broken: 2.79b

Worked: (optional)

Short description of error
Error popup when trying to activate blender_cloud addon after installing addon.
Last 2 lines of error read:

" import urllib3.util.retry
ImportError: No module named 'urllib3'"

Exact steps for others to reproduce the error
Download 2.79b x64 zip for Windows version and extract
Open Blender
Download blender_cloud addon (blender_cloud-1.12.0.addon.zip)
Activate Blender ID addon (able to also reproduce without this step)
Install downloaded blender_cloud addon
Click checkbox to activate addon
See error output

Details

Type
Bug

Related Objects

Duplicates Merged Here
T63274: Blender Cloud

Event Timeline

It appears that urllib3 is not a default module for Python 3.5

Yes, in fact it can be found inside ..\2.79\python\lib\site-packages\requests\packages but you cannot import directly the urllib3 module. Instead it can be imported as a variable:

import requests.packages.urllib3 as urllib3

Aaron Carlisle (Blendify) closed this task as Archived.
Aaron Carlisle (Blendify) claimed this task.

Since last asking for information, it has been 7 or more days, due to the policy of our bug tracker
we will have to archive the report until the requested information is given.