Page MenuHome

Big problem with Blender eevee render
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10
Graphics card: NVIDIA Gerforce 920m

Blender Version
Broken: 2.8 (Blender eevee)

So, when I render a video, about 2000 frames, it always crash (I render with AVI JPG). So I heard about this solution : check the button called "Lock User Interface", so I start the render with that option, and then it render my 6950 frame (need to wait about 11 hours), but then, when I open the video, it was broken, like I can't read all the video, and there is a weird white cross that don't appear in Blender. (Sorry about my English, I'm French). So I let my file to let you see, I hope their is a solution !

Details

Type
Bug

Event Timeline

Really you should never render into a movie format directly to avoid those kind of problems. Just render to JPEG (or better yet EXR if needed) and assemble the individual frames into a movie after the rendering is complete (this can be done in Blender or lots of other programs).

Then you can look at individual frames as they're completed, and if it fails or there is a problem you can always restart the render at the frame that failed, or even later change your animation and just re-render the frames that are affected.

Daria (Divya) added a comment.EditedApr 2 2019, 11:57 PM

So I need to load all the frame one by one in a video editing software to make it into a video ? It's will take ages if I do it like this, there is no more faster way to do this ?

You can feed all your images at once as a sequence to the VSE in Blender and then just render it to the animation format that you like, for example:

https://www.youtube.com/watch?v=LmxaYwmewWs
https://blender.stackexchange.com/questions/52230/how-to-convert-image-sequence-to-video-using-the-vse

Oh thank you, I didnt know it was possible ! I will try that and tell you if it's work !

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

Does this happen with all files (IE the default cube scene) or only with the attached file?

It crash with all the file, but the weird white cross only happen with this file

Are you using the latest nvidia drivers for your card?

So, I try to render in BMP and assemble the individual image,so it's not crash, but the white cross keep showing ! How can I get rid of that ? (I give you one of my .bmp to show you what is the white cross)
And yeah, I use the latest nvidia drivers for my card.

Ok, that's a new one on me. Anyone have an idea?

Every video editing software allows you to drag and drop entire image sequences at once and form a video strip

Sebastian Parborg (zeddb) raised the priority of this task from Needs Information from User to Needs Triage by Developer.

The cross is just caused by a highlight with the Glare node. Either clamp that area of the render or adjust your glare nodes or use other nodes.

So how can I change the nodes ? I'm sorry if I'm long to understand, it's my first time using blender

Next time try rendering into FFmpeg video with container matroska or mp4 or as others have suggested either jpg or png and then assemble the file later differently.

I am closing this, the cross was caused by Glare node.

Adam Preisler (Alphisto) closed this task as Invalid.May 1 2019, 3:06 PM
Adam Preisler (Alphisto) claimed this task.