Page MenuHome

Irradiance Volume baking crashes Blender
Open, Waiting for Developer to ReproducePublic

Description

System Information
Operating system: Ubuntu 18.04
Graphics card: AMD RX 460 & Intel HD 4000

Blender Version
Broken: blender-2.80-40412499433e-linux-glibc224-x86_64 up until latest nightly, blender-2.80-17c15798c35f-linux-glibc224-x86_64. It's worked in the past, before 40412..., but I'm not sure of the commit ID.

Short description of error
Blender crashes a few moments after hitting bake, the bake does start. The error message makes it seem like Blender is picking the wrong GPU driver. I am using the opensource AMDGPU driver not Gallium if I understand correctly, but there is a display plugged directly into each GPU.

DRI_PRIME is set to 1 in /etc/environment
Starting Blender with DRI_PRIME=0 launches Blender on the Intel GPU and the bake completes successfully.
Starting Blender with DRI_PRIME=1 (or not specifying it) launches Blender on the AMD GPU and the crash occurs with the error:

blender: ../src/gallium/drivers/radeonsi/si_descriptors.c:1489: si_desc_reset_buffer_offset: Assertion `old_buf_va <= old_desc_va' failed.

I wanted to see if I could get to the bottom of this myself, but I could not find that file. ¯\_(ツ)_/¯

Exact steps for others to reproduce the error
Add an iridescence volume and hit "Bake Indirect Lighting" on a system with multiple GPUs.

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

What mesa version are you using? (glxinfo | grep OpenGL)

That output file path is from the AMD mesa drivers. I've only ran into output like that when there was a driver bug.

That output file path is from the AMD mesa drivers.

That explains it! XD

Here's my Mesa version:

OpenGL vendor string: X.Org
OpenGL renderer string: AMD Radeon (TM) RX 460 Graphics (POLARIS11, DRM 3.27.0, 5.0.0-2.1-liquorix-amd64, LLVM 7.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.3.3
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.5 (Compatibility Profile) Mesa 18.3.3
OpenGL shading language version string: 4.50
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 18.3.3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

Is this still an issue with either mesa 18.3.5 or 19.0.1?

Philipp Oeser (lichtwerk) closed this task as Archived.
Philipp Oeser (lichtwerk) claimed this task.

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker we will have to archive the report until the requested information is given.

Really sorry about the massive delay! I was finally able to update to Mesa 19.0.2 (and commit 427c75e4c20b), now it only crashes when a view-port is visible while baking.

OpenGL vendor string: X.Org
OpenGL renderer string: AMD Radeon (TM) RX 460 Graphics (POLARIS11, DRM 3.27.0, 5.0.0-2.1-liquorix-amd64, LLVM 8.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 19.0.2
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.5 (Compatibility Profile) Mesa 19.0.2
OpenGL shading language version string: 4.50
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 19.0.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
Sebastian Parborg (zeddb) raised the priority of this task from Needs Information from User to Waiting for Developer to Reproduce.May 12 2019, 11:06 AM
Philipp Oeser (lichtwerk) removed Philipp Oeser (lichtwerk) as the assignee of this task.