Page MenuHome

View Layer doesn't control render visibility
Closed, ArchivedPublic

Description

System Information
Operating system: Win 10
Graphics card: 1080ti

Blender Version
Broken: (example: 2.80, 0e78e3038d02, master, 2019-04-04,

Short description of error
View Layer doesn't control render visibility

Exact steps for others to reproduce the error

  1. Create second View Layer
  2. Disable render visibility of collection or object
  3. Go back to first view layer ==> the collection/object, wich just got disabled in the second view layer, is as well disabled in the first view layer.

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

That's by design and the same as in 2.79.

If you want to control visibility per view layer, right click View Layer > Exclude or press E.

Some changes to the design are being considered here: T61361

Oh sorry, then I mixed it up with render layers. Are those implemented yet?

View layers replace render layers, they have all the same features but with a different UI than 2.79.

But if I want to render collection a in layer a, and collection b in layer b, there is no way to do that, unless I put them in different scenes?

See my answer above about Exclude.