Page MenuHome

Exporting keymap - warnings in console about not matching enums
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-7-6.1.7601-SP1 64 Bits
Graphics card: GeForce GTX 1060 6GB/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 419.35

Blender Version
Broken: version: 2.80 (sub 51), branch: blender2.7, commit date: 2019-03-26 18:57, hash: rB337eb8c1de4c
Worked: (optional)

When i export the Blender 2.7x keymap then i get errors in the console about not matching enums.

Short description of error
[Please fill out a short description of the error here]

Exact steps for others to reproduce the error
[Please describe the exact steps needed to reproduce the issue]
[Based on the default startup or an attached .blend file (as simple as possible)]

Open Blender, open Preferences. Go to Keymap. Switch to Blender 2.7x keymap. Export keymap. Watch console. You will get warnings.

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.Apr 5 2019, 1:26 PM
Sebastian Parborg (zeddb) claimed this task.
Sebastian Parborg (zeddb) closed this task as Archived.Apr 5 2019, 6:33 PM

With some further investigation, this is not a bug.

The enums are not valid so that the user is prompted with a selection dialog when using the shortcuts. (If they were valid a default option would be selected and no prompt will appear)
As these are only warnings and not errors, I'll close this.