Page MenuHome

Vertex snap malfunction with small dimensions
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 419.67

Blender Version
Broken: version: 2.80 (sub 53), branch: blender2.7, commit date: 2019-04-04 19:22, hash: rBb2e2db94bdae
Worked: (optional)

Short description of error
when snapping very close vertices (milimeters between them), vertice snaps to different. I upload a GIF to show better, what happens

Exact steps for others to reproduce the error
In Modeling turn on Vertex Automerge, make very small distance between few vertices on mesh and try to CTRL+mouse snap

F6913577

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) updated the task description. (Show Details)
Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.

Please attach a .blend to reproduce the problem.

Hi, here is the example file. I didn't save it yesterday when working in the moment of error.

But it happened to me a lot of times. I'm using Wacom Intuos 3 tablet when modeling and when snapping in very small distances, the snap jumps to another vertex, even my snap move is correct

Brecht Van Lommel (brecht) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Apr 7 2019, 2:52 AM

Here's scene with the exact situation - if you open with UI load, you should be able to Move (G), Ctrl + wacom tablet snap and try to snap vertices. It will make the bad jump to different nearby vertex.

I just tested with a0608340ae14 and i can't reproduce the error,
Win 7 - nvidia 1070 - Drv 430.86 - Wacom intuos 4 Drv:6.3.8

One thing i notice its the huge amount of addons missing when i opened the file, ¿did you try blender default factory settings to test the bug?

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

@Vojtech Lacina (v01tech) can you still reproduce this?

Demeter Dzadik (Mets) closed this task as Archived.
Demeter Dzadik (Mets) claimed this task.

Closing due to no response in a long time. If you can still reproduce the issue in the latest 2.80 build and with factory settings like belich suggested, feel free to re-open this.