Page MenuHome

"Principled Volume" node not working anymore in EEVEE.
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.17763 64 Bits
Graphics card: GeForce GTX 980 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 419.35

Blender Version
Broken: version: 2.80 (sub 54), branch: blender2.7, commit date: 2019-04-07 00:43, hash: rBd2d84132ddf9
Worked: version: 2.80 (sub 51), branch: blender2.7, commit date: 2019-03-24 00:06, hash: rB79f67acccb36

Short description of error


**UPDATE**
so the bottom line of this seems the be the 4th input "Density Attribute" on the "Principled Volume" Shader. When adding this Shader the Density Attribute is pre-set to "density" which did not cause any issue on the "Worked version" mentioned above.
However, on the newest build "broken" having this default value "density" filled in prevents the Principled Volume Shader from working at all. Removing the value fixes the issue.
This should not happen considering it comes with this value prefilled by default.


"Principled Volume" node not working anymore in EEVEE.
"Volume Scatter" node works.

"Principled Volume" works fine on 79f67acccb36 from 24th march.

Exact steps for others to reproduce the error

plug "Principled Volume" into World Volume.
https://gfycat.com/FamousCelebratedCaterpillar

Event Timeline

Tysa (Tysa) updated the task description. (Show Details)
Tysa (Tysa) updated the task description. (Show Details)

I can not reproduce this on my end (Linux, AMD).

@LazyDodo (LazyDodo) can you reproduce this?

after some more testing: turning up the "Emission Strenght" makes the volume appear with the "Principled Volume" Shader. so it has to be somewhere between the "Principled Volume" Shader and "Volumetric Lighting in EEVEE.
"Principled Volume" works in Cycles btw.

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Also cannot reproduce, in this file, "Scatter" and "Principled Volume" both work:

[only thing I did was to remove the "density" attribute]

@Tysa (Tysa): can you confirm that above file is working on your side?
If so, could you upload your file [which is not working] here?

yes, removing the "density" attribute makes it work. this is weird tho. this was not needed on the old build i used from 24th march.

Old build ( 79f67acccb36 ) screenshot: https://i.imgur.com/mPj2WNZ.jpg

this is the not working file. its really just the default scene, with volumes turned on in eevee settings and principled volume in world output

Tysa (Tysa) updated the task description. (Show Details)Apr 8 2019, 7:31 PM
Tysa (Tysa) updated the task description. (Show Details)
Tysa (Tysa) raised the priority of this task from Needs Information from User to Confirmed, Medium.
LazyDodo (LazyDodo) raised the priority of this task from Confirmed, Medium to Needs Triage by Developer.Apr 8 2019, 7:35 PM

please do not confirm your own bugs

sorry @LazyDodo (LazyDodo) , first time posting. i updated the main post aswell with everything we figured out so far, hope thats okay.

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.

I can actually reproduce this too now. I don't know why I couldn't yesterday. :S

sorry @LazyDodo (LazyDodo) , first time posting. i updated the main post aswell with everything we figured out so far, hope thats okay.

Yeah that's fine, but when a bug goes to confirmed it's assumed the triage team has assigned it a developer, when you put it on confirmed yourself, it's more likely it's gonna fall through the cracks. Triage team won't look at it cause it doesn't need triage, developers won't look at it since it's not listed on their todo list of bugs

Brecht Van Lommel (brecht) raised the priority of this task from Confirmed, Medium to Confirmed, High.Apr 9 2019, 1:27 PM
Ahmad Bilal (SomeAB) added a comment.EditedApr 10 2019, 9:19 PM

Just so it is helpful to track the cause, I'm reposting the version details I posted in the other thread (T63468).

Not Working for me in the build 009dbc2bc9fb (dowloaded today: 10 April), d2d84132ddf9 (April 7) and 700346d377dd (Downloaded April 2).
Working in 1ae6aaad43ad (March 22)

And yes I'm talking about the PV Shader in Eevee, not cycles. Cycles is fine.

My HW: Windows 10 64-bit, AMD Vega RX64

i edited OP a day or two ago with a workaround. check if PV works when you remove the word "density" on 4th input "Density Attribute". @Ahmad Bilal (SomeAB)

yes, I have checked on my side. That workaround is working in 009dbc2bc9fb . Thanks for pointing out.