Page MenuHome

Object with drivers and hooks changes scale when switching to rendered view
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 Pro
Graphics card: Nvidia 2x1080GTX

Blender Version
Broken: 2.80, 009dbc2bc9fb, 2019-04-10
Worked: 2.80, d2d84132ddf9, 2019-04-07

Short description of error
There are two issues going on, both that can't be replicated with a new scene and a cube. I'm not sure what's going on. Both issues are happening within the same file, but I isolated each issue with the least amount of objects in its own blend file because there were hundreds of objects and drivers, so it would be even harder to pinpoint the problem.

First issue (single0x0.blend)
When you switch to rendered view, the "door" object is rendered at a different scale, but the scale values don't actually change.

This issue is not present in older versions of 2.8 (2019-04-07).

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

  • open single0x0.blend file
  • switch to rendered view

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.Apr 11 2019, 10:05 AM

Seems I cannot reproduce [door seems to be the same size in Lookdev and Rendered view...]
(also changing e.g. the hingeHeight prop seems to work OK...)

got a bunch of missing libs [but it appears these are only materials and are probably unrelated]

Read blend: /home/philippo/Downloads/Blender Bugtracker/T63445/single0x0.blend
Info: Read library: '/home/philippo/Downloads/Blender Bugtracker/T63445/materials/metalPaintedWhite.blend', 'materials\metalPaintedWhite.blend', parent '<direct>'
Warning: Cannot find lib '/.../T63445/materials/metalPaintedWhite.blend'
Warning: LIB: Material: 'metalPaintedWhite' missing from '/.../T63445/materials/metalPaintedWhite.blend', parent '<direct>'
Info: Read library: '/.../elfa/materials/plasticGrayTranslucentSmooth.blend', '
..\elfa\materials\plasticGrayTranslucentSmooth.blend', parent '<direct>'
Warning: Cannot find lib '/.../elfa/materials/plasticGrayTranslucentSmooth.blend'
Warning: LIB: Material: 'plasticGrayTranslucentSmooth' missing from '/.../elfa/materials/plasticGrayTranslucentSmooth.blend', parent '<direct>'
Info: Read library: '/.../elfa/materials/plasticWhiteTranslucentSmooth.blend', '//..\elfa\materials\plasticWhiteTranslucentSmooth.blend', parent '<direct>'
Warning: Cannot find lib '/.../elfa/materials/plasticWhiteTranslucentSmooth.blend'
Warning: LIB: Material: 'plasticWhiteTranslucentSmooth' missing from '/.../elfa/materials/plasticWhiteTranslucentSmooth.blend', parent '<direct>'

the there is also missing external files [not sure what BackBottomLeft.py does? -- probably unrelated as well...]:

Warning: Path '/Aplicaciones/Addons/Blender Addons/BackBottomLeft.py' not found
Warning: Path '/.../highres/rooms/hdri/canada_montreal_thea_Small.exr' not found
Warning: Path '/.../highres/rooms/textures/concreteFresco.jpg' not found
Warning: Path '/.../highres/rooms/textures/concreteStucco.jpg' not found
Warning: Path '/.../T63445/materials/metalPaintedWhite.blend' not found
Warning: Path '/.../elfa/materials/plasticGrayTranslucentSmooth.blend' not found
Warning: Path '/.../elfa/materials/plasticWhiteTranslucentSmooth.blend' not found

But just to make sure we are all on the same page: could you upload your file again (with everything packed or added to a zip archive)?
Maybe you could also provide a screenshot showing the difference between LookDev and Rendered?

Again, sorry for all the missing links. Here's the (hopefully) fixed file with no materials and other linked stuff. I also made a video for this issue that hopefully show the issue a bit clearer.

Here's the link to the video
https://youtu.be/cnAydx-Ie0w

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Wed, Apr 24, 11:01 AM
Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Thu, Apr 25, 4:35 PM

I can't reproduce this on my end. Does this still happen for you with the latest blender beta?

I downloaded last night's build and it seems the problem is gone now... go figure.

Sebastian Parborg (zeddb) closed this task as Resolved.Thu, Apr 25, 6:30 PM
Sebastian Parborg (zeddb) claimed this task.