Page MenuHome

Object with drivers and hooks crashes blender when switching to rendered view
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 Pro
Graphics card: Nvidia 2x1080GTX

Blender Version
Broken: 2.80, 009dbc2bc9fb, 2019-04-10
Worked: 2.80, d2d84132ddf9, 2019-04-07

Short description of error
There are two issues going on, both that can't be replicated with a new scene and a cube. I'm not sure what's going on. Both issues are happening within the same file, but I isolated each issue with the least amount of objects in its own blend file because there were hundreds of objects and drivers, so it would be even harder to pinpoint the problem.

Second issue (wall.blend)
When switching to rendered view in the viewport, blender crashes. The console shows a memory error before closing itself.
Error: EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FF741AC7203
Module: C:\B28\blender.exe{F6925444}

This issue is not present in older versions of 2.8 (2019-04-07).

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

  • open wall.blend file
  • switch to rendered view

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.Apr 11 2019, 10:27 AM

Seems I cannot reproduce here [no crash]
I am getting the same missing libs/external files as stated in T63445.

In addition, in this file I get:

[SCScene :: RenderLayer]: BKE_animsys_eval_driver on OBmeshWall (0x7f97f065a608) fcu ["openingWidth"][0] (0x7f97f4e18f88)
ERROR (bke.anim_sys): /blender/source/blender/blenkernel/intern/anim_sys.c:3795 BKE_animsys_eval_driver: invalid driver - ["openingWidth"][0]
[SCScene :: RenderLayer]: BKE_animsys_eval_driver on OBmeshWindowPanesBorder (0x7f97e8fe0008) fcu hide_render[0] (0x7f97f1697a88)
[SCScene :: RenderLayer]: BKE_animsys_eval_driver on OBmeshWall (0x7f97f065a608) fcu ["openingLeft"][0] (0x7f97f4e18008)
ERROR (bke.anim_sys): /blender/blenkernel/intern/anim_sys.c:3795 BKE_animsys_eval_driver: invalid driver - ["openingLeft"][0]

Here, openingLeft and openingWidth custom properties seem to be missing on the meshWall object? If I add these by hand the driver errors go away...

So I suggest to try a couple of things to proceed with this report:

  • could you try "fixing" the two erroring drivers like I did (and see if this will prevent the crash)?
  • if that doesnt work: could you try removing the drivers on visibility (and see if this will prevent the crash)?
  • if that also doesnt crash: could you reupload the .blend with everything packed [just so we are all on the same page and can investigate further...]

Sorry about all the missing files. Here's the (hopefully) fixed file with no materials.

When I added the missing custom properties, something else came up. When I add the custom properties, they are added with drivers already attached to them. No idea what that is all about - maybe it's just me being stupid. Anyway... I made a video of it that hopefully shows the problem a bit clearer. I'm attaching two files this time.
bug_wall_fixedCustomProperty.blend : file with the custom properties that were missing, already added (btw... these custom properties weren't being used, that's why I got rid of them)
bug_wall_addCustomProperty.blend file without the custom properties added. You can add them yourself to reproduce the issue described in the video.

Here's the link to the video
https://youtu.be/HdpJdfNNIHs


Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Apr 24 2019, 11:00 AM
Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Apr 25 2019, 4:40 PM

As with the other report, I can't seem to reproduce this either. Is this also still an issue with the latest blender beta?

I downloaded last night's build and it seems the problem is gone now... go figure.

Sebastian Parborg (zeddb) closed this task as Resolved.Apr 25 2019, 6:31 PM
Sebastian Parborg (zeddb) claimed this task.