Page MenuHome

F12 Key doesn't work properly
Closed, ArchivedPublic

Description

System Information
Operating system: Linux Mint 19.1 (64-bit) Cinnamon
Graphics card: ASUS GTX 1070 Snow Edition OC

Blender Version
Broken: 2.80 Beta - fb4bb611559b Date: 2019-03-15 18:31

Short description of error

Pressing shortcut key F12 for Render Image does not function properly, pressing F12 alone acts like it was never pressed, but if I press Ctrl+F12 for Render Animation it works just fine. I temporarily changed keybind to something else, ie; Shift+Alt+F12 and it works just fine there.

Details

Type
Bug

Event Timeline

Stephen Swaney (stiv) triaged this task as Needs Information from User priority.

Works here in Linux with the 10-Apr daily build.
Your 2019-03-15 is a bit old. Please try with a newer build.

Also, make sure your window manager is not eating F12 before Blender can see it.

Alkaris (Alkaris) added a comment.EditedApr 12 2019, 10:30 AM

My window manager doesn't do anything with F12, nor is anything else bind to that key, I could go to the keybinds section in the Preferences and press F12 but it gets no input response from it. I will try newer build to see if the issue is resolved there.

Further testing with latest build shows the issue with F12 key still doesn't function as intended.

You might try running

xev | grep F12

from the command line and pressing F12.
You should see something like this:

state 0x10, keycode 96 (keysym 0xffc9, F12), same_screen YES,
state 0x10, keycode 96 (keysym 0xffc9, F12), same_screen YES,
Alkaris (Alkaris) added a comment.EditedApr 12 2019, 4:07 PM

Definitely works when I do that, not sure why Blender is unresponsive when I press the key.

$ xev | grep F12
    state 0x10, keycode 96 (keysym 0xffc9, F12), same_screen YES,
    state 0x10, keycode 96 (keysym 0xffc9, F12), same_screen YES,
    state 0x10, keycode 96 (keysym 0xffc9, F12), same_screen YES,
    state 0x10, keycode 96 (keysym 0xffc9, F12), same_screen YES,
    state 0x10, keycode 96 (keysym 0xffc9, F12), same_screen YES,
    state 0x10, keycode 96 (keysym 0xffc9, F12), same_screen YES,
Stephen Swaney (stiv) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Apr 12 2019, 6:41 PM

Interesting. The only thing I can think of is something (usually a window manager) is grabbing the key.
No idea what.

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

I can't reproduce this on my end either.

Does it work if you load factory defaults? Are you using the default keymap and you haven't managed to bind F12 to something else by mistake?

I'm using default key mappings, and as I've already stated before, nothing else is bound to F12 or taking control over it. Key works for every other application except Blender, even tested it out in 2.79, same effect there.

Sebastian Parborg (zeddb) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Apr 12 2019, 9:19 PM
Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

@Alkaris (Alkaris) : you are saying you are using default key mappings, but have you also tried File > Loading Factory Settings? [I am asking just to make sure no addon interferes here...]

If you run blender with --debug-events, do you see something like the following?

wm_event_do_handlers: Handling event
wmEvent  type:311 / F12, val:2 / RELEASE,
         shift:0, ctrl:0, alt:0, oskey:0, keymodifier:0,
         mouse:(621,231), ascii:'', utf8:'', keymap_idname:(null), pointer:0x7fd1d3b25888

I did all of that yes.

I'm beginning to think this might be an issue with ibus input. It's quite common for ibus inputs to sometimes not work correctly with applications because they're not mapped correctly and usually need an override modifier to fix the issue.

Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

Don’t think we can do much here, this seems to be related to something on your specific hardware/software config… Thanks for the report anyway.