Page MenuHome

Deleting GPencil object leaves topbar in Draw Mode
Closed, ResolvedPublic

Description

System Information
Operating system: Microsoft Windows 7
GPU: ASUS Strix Radeon Vega 64
CPU: Intel(R) Core(TM) i7-5960X
RAM: 32.0 GB
Full System Information: Here

Blender Version

Broken: 2.80, blender-2.80.0-git.009dbc2bc9fb-windows64
Worked: N/A

Short description of error

Deleting GPencil object leaves 3D view/topbar in Drew Mode.

Exact steps for others to reproduce the error

  • Open 2D Animation template
  • Goto Outliner and Delete stroke
  • The topbar shows empty brushes

Note: the topbar doesn't refresh right away.

Details

Type
Bug

Event Timeline

Antonio Vazquez (antoniov) triaged this task as Confirmed, Medium priority.Apr 12 2019, 8:57 PM

The problem is the when delete an object, must back to Object mode as it's done with meshes.

@Campbell Barton (campbellbarton) @William Reynish (billreynish) I have seen a problem with topbar (the same I have in grease pencil) for other objects.

Try this:

  1. Open default scene.
  2. Select Cube and enter in Edit mode.
  3. Select any tool, for example Bevel.
  4. Delete the object using the Outliner.
  5. The mode changes to Object, but the tool in Topbar is still Bevel.

IMHO, in this situation, the tool must be reset to Selection.

Antonio Vazquez (antoniov) removed Antonio Vazquez (antoniov) as the assignee of this task.

I'm going to reasign to @Campbell Barton (campbellbarton) because it looks a more general topbar issue.

Brecht Van Lommel (brecht) closed this task as Resolved.

This appears to be fixed now.