Page MenuHome

BlenderKit Addon doesn´t connect to the internet
Open, Needs Triage by DeveloperPublic

Description

System Information
Operating system: Windows 10 Pro, 64-bit, i7-6700K CPU, 16GB RAM
Graphics card: NVIDIA GeForce GTX 970

Blender Version
Worked:
blender-2.79.0-git.5d5070dd1232-windows64
Worked:
blender-2.80.0-git.009dbc2bc9fb-windows64

Short description of error

After selecting a category (Asphalt) the connection is aborted due to a TimeoutError(10060) which leads to not finding any matching results. Same problem for Version 2.79 and 2.80 with and without firewall turned off. Any solutions for this issue?

Based on the default startup.

Thanks

Details

Type
Bug

Event Timeline

It's working here for me now. Can you try again and see if you still have the issue? Perhaps their server was down when you tried it originally.

Also did you create an account and install your API key into the Add-on Preferences?

The add-on outputs a substantial amount of debugging information to the console that might be helpful.

Thank you for your comment.

I created an account yesterday and my API key was installed into the Add-on Preferences.

It's not working ...

Gavin Scott (Zoot) added a comment.EditedApr 14 2019, 1:39 AM

Probably your best bet would be to contact the BlenderKit guys at the email address info@blenderkit.com since they're the ones who support this addon and its related services.

I do see that the main URL the add-on tries to connect to looks like it is:

https://www.blenderkit.com/api/v1/

if I just go to that address in a web browser, I get a Django API error page with "detail": "Authentication credentials were not provided." which is the sort of thing I would expect.

If you don't get that far then it might be some sort of network issue on your end (DNS or whatever), but if you get the same thing I do there then it's probably something related to the add-on on your system and the BlenderKit guys will probably have to help figure it out.

Thanks for assigning, please always assign task related to this add-on to me, I'm the main developer of it.
Indeed this can be potentially DNS issue, please try to do as Gavin Scott suggested, open this address in the browser:
https://www.blenderkit.com/api/v1/

If you can't connect to the server this way too, it might be your DNS settings.