Page MenuHome

OSX: 2.8 App icon
Closed, ResolvedPublic

Description

System Information
Operating system: Darwin-16.7.0-x86_64-i386-64bit 64 Bits
Graphics card: NVIDIA GeForce GTX 780M OpenGL Engine NVIDIA Corporation 4.1 NVIDIA-10.17.5 355.10.05.45f01

Blender Version
Broken: version: 2.80 (sub 53), branch: blender2.7, commit date: 2019-04-02 19:53, hash: rBa813e259d630
Worked: (optional)

Short description of error
Application icon is darker only on mac.

Exact steps for others to reproduce the error
Looks like app icon goes darker and darker under OSX
From top 2.79, older 2.8, current 2.8 (for a few months?)

I would think its redesign, but from what I saw today, Windows10 icons keeps colour consistency, even with 2.79 (it use flat icon already), so it's not probably wanted so dark.

Details

Type
Bug

Event Timeline

@Francesco Siddi (fsiddi) As the official 'brand' tzar, can you give some guidance in this area? I should be able to fix issues in this area.

Desktop icons on Windows, Linux and Mac OS are different. The correct application icon is the very first. Flat icons are not accepted at all.
This is indicated on the website: https://www.blender.org/about/logo/

The correct Blender icon IS flat and orange, not shaded and yellow. But I will let @Francesco Siddi (fsiddi) do a guidance in the app icons.

filip mond (vklidu) added a comment.EditedApr 15 2019, 6:31 PM

"... Flat icons are not accepted at all."

@Characterhero: I don't see any word in that meaning.
Page in your link says only "... the logo shape has to remain correct and recognizable. "
I don't see a problem in that area.
Shown examples just fits to an icon style in that time (of creation) used in OS.

BTW
https://developer.blender.org/rB18cb27b4f49054cc3a2455d5b67fafde3b86c1e4#change-Et4gg91Sttof

Or how would you call this version :)
https://devtalk.blender.org/t/updated-linux-app-icon-for-2-8/5888

I don't see a problem in that area.

I mean, if you install Blender on Mac OS and Linux, they will be the same. But in Windows version the icon is different flat. The icon should be the same in all operating systems.

I updated the Logo Guidelines to feature more prominently the actual logo colors. Over the years the Blender logo drifted away from its original colors, so recently I sat down with Ton to confirm the original PMS values, which are specified in that page. The translation to hex values has been done through https://encycolorpedia.com/. Please use those colors to make an App Icon.

If @William Reynish (billreynish) could kindly check on what colors are used in the current icon (probably different colors) and conform them to the official colors, I would appreciate.

For the record, the icon proposed here does not use the correct colors.

Thanks @Francesco Siddi (fsiddi), I will check. There might be some kind of gamma issue with converting the images to icons.

In the Blender logo kit all SVG and PNG contains these color value:

PANTONE 716 C = #EA7600 (RGB 234 118 0)
PANTONE 647 C = #236192 (RGB 35 97 146)

While the encycolorpedia.com links and blender_colors_pms.png contains other color:

Pantone / PMS 716 = https://encycolorpedia.com/e87d0d
Pantone / PMS 647 = https://encycolorpedia.com/265787

You are right @Yevgeny Makarov (jenkm). I will fix the files as soon as I have access to them.

@Francesco Siddi (fsiddi) If you can generate correct app icons I can easily commit them




Colors:
#e87d0d
#265787


fixed logo kit




for websites


@Yevgeny Makarov (jenkm) Thanks for these.

However, I noticed that the native Mac document icons don't have the folded page built-in. The final icon seems to be composited by the OS:

So ideally I think we should do the same for Blender, but not sure exactly how we set this up, or if it happens automatically?

No, it's just the style of these particular icons, check out the others.

I can create an icon based on GenericDocument.icns, but not sure about copyright.

@William Reynish (billreynish) This version based macOS GenericDocument icon.

/System/Library/CoreServices/IconsetResources.bundle/Contents/Resources/Artwork

Fantastic work @Yevgeny Makarov (jenkm). Thank you for so carefully preparing the files, it saved a lot of time.
All files and images are now updated on blender.org/about/logo

Brecht Van Lommel (brecht) closed this task as Resolved.

New icons were committed, assuming this is solved.