Page MenuHome

Emission Shader Light Does Not Reflect Correctly in Glossy Surface
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10 64 bit
Graphics card: GeForce 1050 TI

Blender Version
Broken: 2.80, 5d8030b8f3cf, master, 2019-04-17

Short description of error
Emission shader in Cycles applied as material and set to a certain color and set to strength higher than 1 still gets reflected as strength 1. For example, red color is used in an emission shader, strength is set to 5, the object becomes almost white with some glow. But a reflective/glossy object nearby still reflects it as just red, as if strength was 1.

Exact steps for others to reproduce the error

  1. Use Cycles engine
  2. Create a plane, make it glossy (decrease roughness) in Principled BSDF.
  3. Create a plane on top of it, use Emission node for it as a material.
  4. Set Emission color to pure red, set Emission strength to 5
  5. Render with Cycles
  6. Emission object will be white (due to Emission strength), while reflection of it will be red.

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.EditedApr 17 2019, 7:43 PM
Brecht Van Lommel (brecht) claimed this task.

There's no bug here that I can, see this just how physics works for a material with a black diffuse layer and some specular layer on top. It's going to be darker from most viewing angles.

If you want light to be reflected with exactly the same value you need a perfect mirror, with base color to 1.0, metallic to 1.0, and roughness to 0.0.