Page MenuHome

FBX export suddenly broken
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.17763 64 Bits
Graphics card: GeForce GTX 1080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 391.35

Blender Version
Broken: version: 2.80 (sub 57), branch: master, commit date: 2019-04-16 20:13, hash: rB5d8030b8f3cf
Worked: any version before 2019-03-27

Short description of error
[fbx export of animated and rigged character is broken. hand/arms go nuts. i can change versions just to fix the issue. any earlier version than march 27 still works.]

Exact steps for others to reproduce the error
[i reproduced it with my armature in any case. it only doesnt appear if i export without any animation data or keyframes. if i add a single keyframe and export the character again it gets broken.
I also tried to reimport the broken file to see the results and it seems still broken. however i could see that the armature wasnt broken but the skinning somehow instead(see added picture)]

exported:

in Blender:

reimported broken fbx file in blender:

heres a blend file where that happens. also keep an eye on the foot Constraints, they are broken too but i might report another bug later as a new issue.

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) claimed this task.

If you can't provide any steps to reproduce the issue, there is not much to do here.

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.
Fatih Yilmaz (AquilaGames) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Apr 19 2019, 8:34 AM
Fatih Yilmaz (AquilaGames) updated the task description. (Show Details)
Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Apr 19 2019, 12:27 PM

Can you provide a sample .blend file so we can reproduce this issue ourselves?

Fatih Yilmaz (AquilaGames) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Apr 19 2019, 2:09 PM
Fatih Yilmaz (AquilaGames) updated the task description. (Show Details)
Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.

The sample file from T63721:

As @Sebastian Parborg (zeddb) mentionned, apparently the "to_mesh" call in the fbx binary export script is not working as it should because it's converting to mesh the model with armature modifiers applied, whereas they are disabled a few lines above in the script (to reset to the rest pose).
Seems to be an update issue. Triggering the data update manually using bpy.context.scene.update() just before "tmp_me = ob.to_mesh..." make it work. Not sure it should be fixed this way though?

Sergey Sharybin (sergey) closed this task as Resolved.Fri, May 17, 1:08 PM

This issue is fixed by the series of commits to the dependency graph API changes and fixes.
Thanks for the report, closing it now.