Page MenuHome

Grease pencil attributes added to regular material
Closed, ResolvedPublic

Description

System Information
Operating system: linux Mint
Graphics card: Nvidia 1070

Blender Version
Broken: 2.8 4439e5d0ba3f
Worked: (optional)

Short description of error
Grease pecil attributes on regular materials on file load.

Exact steps for others to reproduce the error
Getting grease pencil attributes added on some regular materials on file load.
Allready have such error reported ~10 days ago.

Event Timeline

Christopher_Anderssarian lowered the priority of this task from 90 to 30.Apr 18 2019, 6:42 PM

If you are talking about the Annotation layers showing up, then that's intended behaviour.
(see T63455: Legacy GPencil settings in Annotations).
Is that what you mean?

Nope, select the object and take a look at material,
you should see typical grease pencil attributes on it, stroke and so on, and i definitely not expect those params on regular material.

Christopher_Anderssarian raised the priority of this task from 30 to 90.EditedApr 18 2019, 6:57 PM

Ah I see...
AttributeError: 'Mesh' object has no attribute 'use_stroke_edit_mode'

@stephen leger (stephen_leger) Any Idea how to reproduce? (from scratch)

@Antonio Vazquez (antoniov) Known issue?

I cannot reproduce it. I have created a file in 2.79 and loaded and all is ok, then created a new file in 2.80, open it again and not problems.

When need a reproducible step by step guide to analyze this bug.

Are you using any add-on?

Don't know how to repro, it suddenly appear on a file after loading.
Looks like it's probably related to Annotation.

Had another user with same issue ~ 29.03.2019

Antonio Vazquez (antoniov) lowered the priority of this task from 90 to 30.Apr 18 2019, 7:15 PM

Maybe there was a name conflict when the materials for annotations was created... but not sure. We will wait until you are able to reproduce consistently to go deeper in the problem.

Archipack, is enabled,
but double checked material loading 29.03 and not it does check and when gp attr are found skip material and never apply it.
So i cant imagine it's related to this one.

Root of this issue still not known, but it occurs. It's clearly related to use of annotations.
So maybe keep open with a lower priority in order to gather more information from other users.

At this time it is impossible to remove gp related parameters from materials, so current workaround is to re-create material and related nodes, but would have been lot easyer if we are able to simply remove gp attr.

Ok, we will keep open waiting to get the exact steps to reproduce it.

Bastien Montagne (mont29) lowered the priority of this task from 30 to Low.May 16 2019, 12:03 PM

Same trouble in T71533 in 2.81. Guys, it's really should be high priority. All workflow going down with this bug...

Philipp Oeser (lichtwerk) raised the priority of this task from Low to 80.Nov 13 2019, 11:59 AM

Some more examples in T71533: Object material turns to Grease Pencil materials - Bug , but really seems to be the same roots...
Will raise prio, trying to find reproduction steps...

I'm getting this too. Only really got it since I started switching between 2.81 and 2.82. Though I'm not certain that's what triggered it.

I have committed a patch to separate GPencil objects and Annotations. Not sure if this fix this bug because we were not able to reproduce, but maybe this solves the issue.

Waiting to find a way to reproduce it if the bug still exists.

Richard Antalik (ISS) closed this task as Resolved.Tue, Jan 21, 12:46 AM
Richard Antalik (ISS) claimed this task.

Will close this for now, if somebody will come across this issue with new builds, please let us know.