Page MenuHome

physics calculation speed very slow in scenes with lots of scattered objects on non visible layers
Closed, ArchivedPublic

Description

System Information
Operating system: win 10 pro
Graphics card: 1070, driver : 25.21.14.1935
ram 32gb ddr4
processor i7 7700k

Blender Version
2.79b

slow physics calculation in scene with lots of scattered objects (hair particle system foliage).

I can't share the file as it's a client file, but basically I have a scene with lots of scattered foliage using hair particle systems (no dynamics), and some high poly geometry (not scattered). I've added a tank to the scene, and have set up the tracks to be driven by mesh cogs using physics (see this tutorial if you want to recreate https://www.youtube.com/watch?v=q5fjslhomsI&t=234s).

The problem is that even though I only have the layer visible which has the tracks and wheels, and there's nothing else in the scene which has physics/dynamic, the physics calculation is exceptionally slow (1fps), however if I copy the tracks and wheels to a new file, then the physics is calculated at 60fps with the same settings...even if the other file is still open (indicating not a system resource issue)

Details

Type
Bug

Event Timeline

michael campbell (3di) closed this task as Invalid.Apr 19 2019, 1:49 AM
michael campbell (3di) claimed this task.

Scrap that, after searching the scene item by item (I didn't create the file), I found that there was one object nestled amongst several hundred that had an array modifier on it! Resolved the playback speed by replacing the array with dupli groups.....I pray for the day that we can have an instance array modifier like we have in Houdini.

Sorry for the false alarm.

Cheers
Michael.

michael campbell (3di) reopened this task as Open.Apr 19 2019, 2:32 AM

one thing that might be a bug though (can't imagine it's by design)....when things are hidden, either by having the layer switched off, or the object not visible, is there any point in it's modifiers being calculated during anim player playback?

We still have some optimizations to do in this area, and plan to change the user interface so the option to fully disable options instead of temporarily hiding them is more prominent. This is not considered a bug currently though.

Thanks Brecht, that's great news, as this is crippling workflow at the moment. Perhaps an option to only calculate selected objects during anim player playback would also be beneficial (making live playback as fast as manual scrubbing( dependant on what's selected))......and an instance array modifier for arrays that don't need to be deformed or result in one merged object....requested here:

https://blender.community/c/rightclickselect/QWcbbc/