Page MenuHome

emissive ignored when importing .obj
Closed, ArchivedPublic

Description

System Information
Operating system: linux
Graphics card:GeForce GT 440

Blender Version
Broken: 2.79b
Worked: (optional)

Short description of error

The "Ke" line in .mtl file is ignored when importing a .obj file.

Exact steps for others to reproduce the error
Start from default scene, delete cube, import attached .obj file.
Open the active object properties panel, material tab.
Emissive reads 0 whereas (if I'm not mistaking) it should read 2.

Regards and thank you !

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Confirmed, Medium priority.

Will confirm for now [because atm. it is indeed ignored].
There was rBA94c9c4ee3370, but since the move to Principled BSDF it is ignored and this seems to be a known issue.
There is also a warning already:
WARNING, emit value unsupported by Principled BSDF shader, skipped.
It is a bit unclear how to handle this properly.

@Bastien Montagne (mont29): should this just mix in an Emission Shader? Or should we just live with the fact that emissive does not fit well the current workflow?

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

We'll add an emission socket to the principled BSDF later, for now this is not considered a bug but a known limitation.