Page MenuHome

Toggle Fullscreen Area: Shortcut and Search not functional
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 7 x64
Graphics card: Nvidia GeForce GTX 760

Blender Version
Broken: 2.80, b46245470f79, branch blender2.7, 2019-04-17

Short description of error
The default shortcut of the "Toggle Fullscreen Area" (Ctrl+Alt+Space), as defined in menu point View -> Area is not working.
Furthermore, the action is not indexed in the search function (F3). That one may be another issue, though.

Exact steps for others to reproduce the error

Shortcut Bug:

  1. Press Ctrl + Alt + Spacebar
  2. No toggle is performed

Index Bug

  1. Press F3
  2. Type in "Toggle Fullscreen Area" ("Toggle full" is sufficient)
  3. No entry for the specified action appears

Details

Type
Bug

Event Timeline

I also noticed the same on MacOsx. The Toggle Fullscreen works in all the editor except the 3D View.
But once I reset to factory settings it went fine.
It seems there is a conflict with the "Pie Menu : Official UI Pie Menu" addon, because it shows me an empty Manipulator kind of pie (see image) .


Are you sure you have Vanilla blender ? Can you try if it still happens when you factory reset?

I tested it with the stated version (build date: 2019-04-17), as well as with a self-compiled version from master branch (last commit 22.4.2019 @ 15:10 / 7d6a9b551759cf3f1cca0c6d8ecb1459d02dcc28).

I also checked the factory reset you mentioned. Still the same behavior for me (no toggle and no search result on F3).
Something OS-specific (Win7 vs Win10) seems unlikely, since other Ctrl-Alt combinations are working fine, and Ctrl-Alt-Space is not assigned otherwise.

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Working fine here.

reg. no shortcut: is this possibly mapped to something on the OS side?
reg. no search: the operator is called "Toggle Maximize Area" (Toggle Fullscreen Area is the same op, it just uses a setting to additionally hide all panels...)

I checked it on another Win10 machine and the shortcut worked there (partially).
I have to check it later on the other Win7 machine, whether the locale or another application is interfering.

However, there seems still to be an odd behavior of the toggle function.

Exact steps for others to reproduce the behavior

  1. Open Blender
  2. Press Ctrl+Space (window toggles)
  3. Press Ctrl+Alt+Space

--> Window not toggling anymore (also if Ctrl+Alt+Space is pressed multiple times)

  1. Press Ctrl+Space (window is toggling back)
  2. Press Ctrl+Alt+Space

--> Window is toggling (also if Ctrl+Alt+Space is pressed multiple times)

Is this behavior intended? It seems to be a bit confusing

Philipp Oeser (lichtwerk) closed this task as Archived.
Philipp Oeser (lichtwerk) claimed this task.

regarding the "odd" behaviour:

  • the operator is going back and forth between SCREENNORMAL and SCREENMAXIMIZED (Ctrl+Space)
  • the operator is going back and forth between SCREENNORMAL and SCREENFULL (Ctrl+Alt+Space)

SCREENMAXIMIZED /* one editor taking over the screen */
SCREENFULL /* one editor taking over the screen with no bare-minimum UI elements */

  • If you perform step 2. above you go into SCREENMAXIMIZED
  • if you then perform step 3. above you are trying to toggle back to SCREENNORMAL from SCREENFULL (but you are not in SCREENFULL so operator is doing nothing...)

So this should be seen as pairs, I guess, and cant toggle between maximized and full...
While this could be made working and might be confusing, I guess this is not a bug....

Will close this (unless @Brecht Van Lommel (brecht) or @William Reynish (billreynish) have objections?)
@Raphael Stoeckli (rabanti): feel free to reopen/comment again if issues persist on the Win7 machine [but it certainly looks like something specific in that particular OS setup...]

OK, figured it out. No Blender-related issue, sorry.
It was a bloody MIDI-Synthesizer (was loaded by the web browser for no good reason) that used Ctrl-Alt-Space as "panic" button. Case closed.

However, regarding the search function:
Neither "Toggle Maximize Area" nor "Toggle Fullscreen Area" is available by the search (F3). But this may be not a bug but a future improvement to add more functions to the index

Thx for getting back
"Toggle Maximize Area" is showing up in F3 search on my side...

You're right. It is only "Toggle Fullscreen Area" missing.
I don't know what I was looking at, yesterday. But I have to double-check such things in the future.