Page MenuHome

Crashing file
Closed, DuplicatePublic

Description

System Information
Operating system: elementaryOS 0.4.1
Graphics card: GTX 1080

Blender Version
Broken: 2.80, 5a144c797a3b
Worked: 2.80, a few days before that

Short description of error
Blender has been very crashy for me the last days, sometimes quite randomly (though I think this has been fixed with rB5a144c797a3b5385b0a85027d4bfbf2c3b7ee69d). Here's one occasion where I can redo it, even after the fix mentioned before.

Exact steps for others to reproduce the error
Open this file and go to Shading Workspace. Crashes every time for me.

Blender 2.80 (sub 58), Commit date: 2019-04-23 12:31, Hash 5a144c797a3b

backtrace

/home/sebastian/01_Blender/git/cmake/bin/blender(BLI_system_backtrace+0x30) [0xc099b0]
/home/sebastian/01_Blender/git/cmake/bin/blender() [0xa1b081]
/lib/x86_64-linux-gnu/libc.so.6(+0x354b0) [0x7f0a3b52b4b0]
/home/sebastian/01_Blender/git/cmake/bin/blender(GPU_generate_pass+0x479) [0x27f5a69]
/home/sebastian/01_Blender/git/cmake/bin/blender(GPU_material_from_nodetree+0x159) [0x2801809]
/home/sebastian/01_Blender/git/cmake/bin/blender(DRW_shader_create_from_material+0x75) [0x1238eb5]
/home/sebastian/01_Blender/git/cmake/bin/blender(EEVEE_material_mesh_get+0xfd) [0x11f76ad]
/home/sebastian/01_Blender/git/cmake/bin/blender(EEVEE_materials_cache_populate+0x11e0) [0x11f9100]
/home/sebastian/01_Blender/git/cmake/bin/blender(EEVEE_cache_populate+0x103) [0x11eb173]
/home/sebastian/01_Blender/git/cmake/bin/blender() [0x11cf391]
/home/sebastian/01_Blender/git/cmake/bin/blender(DRW_draw_render_loop_ex+0x261) [0x11d0a81]
/home/sebastian/01_Blender/git/cmake/bin/blender(view3d_main_region_draw+0x77) [0x14a1937]
/home/sebastian/01_Blender/git/cmake/bin/blender(ED_region_do_draw+0x899) [0x1516249]
/home/sebastian/01_Blender/git/cmake/bin/blender(wm_draw_update+0x485) [0xe07c35]
/home/sebastian/01_Blender/git/cmake/bin/blender(WM_main+0x30) [0xe05350]
/home/sebastian/01_Blender/git/cmake/bin/blender(main+0x2fc) [0xa053ac]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0) [0x7f0a3b516830]
/home/sebastian/01_Blender/git/cmake/bin/blender(_start+0x29) [0xa175f9]

Details

Type
Bug

Event Timeline

The file opens just fine for me.

OS: Linux-4.18.0-17-generic-x86_64-with-Ubuntu-18.04-bionic 64 Bits
GPU: Quadro RTX 6000/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 418.56

It opens fine for me as well, but as soon as I try to go to Shading Workspace it crashes, even with factory startup.

Okay, must be some local problem, on my other machine it doesnt crash. Trying make clean now.

@Jacques Lucke (JacquesLucke) Ok, I have been able to locate the possible root of the issue. It's related to the 'Object' setting in Texture Coordinates nodes in the object's material.
If I remove the entry in the Object field (in this case it's 'HLP_center.001'), I can go to Shading Workspace just fine.
In fact, if I create a new file with a new material, go to LookDev mode, add a texture with a mapping node and put e.g. the Light in the Object text field, Blender crashes immediately. At least it does for me.
I have rebuilt from scratch, even tried to build dependencies again, but still it crashes. The build from buildbot however doesnt. I have no idea what's going on. Obviously you cannot debug my system, but maybe you have an idea where the problem might come from?
My NVIDIA driver is also 418.56, btw.

I have the same crash when i switch to shading with the blend file.