Page MenuHome

Top bar stays hidden forever when you tick hide option
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10 64-bit
Graphics card: Nvidia GTX 1070 8gb

Blender Version
Broken: blender-2.80.0-git.5a144c797a3b-windows64

Short description of error
Hello there, wonderful people of Blender development community!

I'm having a trouble with a new top bar. Upon hiding it, it just stays hidden and never comes back even if you click on options to show it again. I've attached a video file to demonstrate the bug.

Exact steps for others to reproduce the error

1- Open blender
2 - Hide top bar
3- Try to unhide top bar

Or watch video:

P.S. I'm really sad about the new top bar, I know I'm probably in the minority of people that loved transformation orientation and pivot center option tabs (the ones that were overlayed in the middle) tab directly in the viewport and the ability to hide top bar completely to win some viewport space while having transform orient and pivot center menus in the viewport. Latest topbar is useful in sculpting and drawing modes, but in edit mode, I prefer to have as much viewport area as possible and jam there. Now it feels like 2.79 interface is back =((. I know I'm whining and nitpicking, but I hoped you will keep those options available when you've announced top bar redesign =)). Sorry, for off-topic , you guys are still the best =*. ^_^

Details

Type
Bug

Event Timeline

I guess the global header toggle just needs to be removed...
Actually there needs to be a easier way to bring the the tool setting back. The only way in the viewport is to right-click close to a header icon...


As to the latter part of your P.S.
You can 'fake' a top bar by having a 3D View and only showing a header, then Ctrl spacing to full window and back, might help your workflow a little bit...

Philipp Oeser (lichtwerk) triaged this task as Confirmed, Medium priority.

Still have to read upon the whole matter [where toolsettings are actually displayed if you hide them from the header -- are they supposed to be shown in the Properties Editor > Active Tool & Workspace Settings > cant see editmode toolsettings there...?], I can imagine this is still WIP?

Anyways, being able to bring them back easily once hidden sounds important, maybe we should integrate the header menu into the VIEW3D_MT_view [since this is now per editor]?

@Campbell Barton (campbellbarton) , @William Reynish (billreynish) : what do you think?

[Will confirm for now until someone else decides differently...]

I guess the global header toggle just needs to be removed...
Actually there needs to be a easier way to bring the the tool setting back. The only way in the viewport is to right-click close to a header icon...


As to the latter part of your P.S.
You can 'fake' a top bar by having a 3D View and only showing a header, then Ctrl spacing to full window and back, might help your workflow a little bit...

I'll try to be more clear. I am unhappy to have pivot/orientation/snap options moved to the topbar from the header, making us forced to keep the topbar on (assuming that absolutely all users want to always have topbar visible).

Still have to read upon the whole matter [where toolsettings are actually displayed if you hide them from the header -- are they supposed to be shown in the Properties Editor > Active Tool & Workspace Settings > cant see editmode toolsettings there...?], I can imagine this is still WIP?
Anyways, being able to bring them back easily once hidden sounds important, maybe we should integrate the header menu into the VIEW3D_MT_view [since this is now per editor]?
@Campbell Barton (campbellbarton) , @William Reynish (billreynish) : what do you think?
[Will confirm for now until someone else decides differently...]

In previous builds we had Window -> Show Top Bar option that would turn Topbar on and off. Now we can right-click to hide it, but when we click to show it again it is not turning back on for some reason (at least it's not working for me). So this is certainly a bug.

Now my main issues are that pivot/orientation/snap options moved to the topbar from the header which forces me to have top bar to be always on in edit or object modes and having more vertical space when you hide topbar is not an option now. Actually, hiding topbar is not viable now if you still want to be able to use pivot/orientation/snap options as they were moved to the topbar from the header. This problem in a certain way has been mentioned in this thread: https://developer.blender.org/D4721

Also in previous builds we could hide and unhide the topbar by dragging. You would need to click and drag the edge of the viewport, now we can't.

Anyways, being able to bring them back easily once hidden sounds important, maybe we should integrate the header menu into the VIEW3D_MT_view [since this is now per editor]?

Best would be near edge, top or bottom, depending on their location.
You might want to check D4736 before start working on that.

@Chingiz Jumagulov (Krayzmond) Totally agree. Need to be able to drag Tool header. And also, should move the buttons down, when hidden.
These two small arrow are too easy to miss.


They exist, to make possible resizing, when regions are hidden.

Campbell Barton (campbellbarton) closed this task as Invalid.EditedApr 26 2019, 5:01 AM

There is a downward pointing drag arrow you can click on to expand it again (just above the view axis manipulator).

closing.


Note that design here could be improved but this isn't a bug/error in the code.

@Campbell Barton (campbellbarton) There isn't a drag arrow when the 'tool settings' are hidden... (see T63835#665239)

Yup, if you press hide 'tool settings' there's no way to bring the top bar and header back.

Yup, if you press hide 'tool settings' there's no way to bring the top bar and header back.

For now, right click on the headers buttons to restore.