Page MenuHome

weird side-effects of ctrl-z
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-4.18.0-2-amd64-x86_64-with-debian-buster-sid 64 Bits
Graphics card: GeForce GTX 745/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 390.87

Blender Version
Broken: version: 2.80 (sub 58), branch: master, commit date: 2019-04-23 12:31, hash: rB5a144c797a3b
Worked: 2.79

Short description of error
Undo button has unexpected effects

Exact steps for others to reproduce the error
change something/multiple things in the scene, press undo (ctrl-z).
Effects:

  • unexpectedly switches to a different object and into edit mode
  • seemingly reloads start-up file
  • possibly other effects

any file

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

I can not reproduce. You will have to come up with some better step to reproduce this issue.

Just "do something and then undo" is not going to cut it.

Hi. Do you still have the problem loading Factory Settings?
Open Blender 2.8. In "File" Menu, load Factory Settings and accept. Do the test now to see if the problem persists.
Close Blender.

Note that the undo system in Blender 2.8 was intentionally changed to work as a single linear undo stack. That means it will automatically switch modes as you undo/redo changes that were made in different modes.

bjoern brandt (hereiam) closed this task as Resolved.Apr 25 2019, 7:11 PM
bjoern brandt (hereiam) claimed this task.

can't seem to replicate in today's version or after turning on "global undo" either, sorry to bother you

YAFU (YAFU) added a comment.EditedApr 25 2019, 7:23 PM

can't seem to replicate in today's version or after turning on "global undo" either, sorry to bother you

Related to that was my question oriented. I also use Linux. About a week ago Undo system stopped working completely on my machine. Then I realized that the Global Undo option was disabled, so I enabled it and Undo worked again.
I thought that possibly I had accidentally disabled Global Undo, but now I'm not sure if it happened because some resent version of Blender 2.8 changed or corrupted my user configuration in some way

There are add-ons that temporarily disable global undo, then encounter some exception, and don't properly enable it again then. It's such a common bug in add-ons that we may have to work around it on the Blender side.