Page MenuHome

Blender freezes for 5 seconds when I change values in the "Pop up box"
Closed, ArchivedPublic

Description

System Information
Operating system: macOS Mojave 10.14.2
Graphics card: Radeon Pro 560X 4096 MB
Intel UHD Graphics 630 1536 MB

Blender Version
Broken:
2.80, 1b839e85e142, blender2.8, 2019-04-25
Download file is blender-2.80-1b839e85e142-OSX-10.9-x86_64

Short description of error

Whenever I make changes in the pop up box they take way longer than when I just type the value and enter.

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

Scale the object by 2 by pressing S > 2 > Enter.
Scale the object by pressing S > Enter and changing the value to 2 on the pop up box. It freezes Blender for around 5 seconds.


Details

Type
Bug

Related Objects

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.Fri, Apr 26, 2:55 PM

It seems like the GUI element invalidates the subsurf cache while the shortcut doesn't.

Brecht Van Lommel (brecht) closed this task as Archived.Tue, May 7, 3:38 PM

This is not a bug, even though it would be good to optimize this once. The operator settings tweaking is based on undo/redo which is slower than the interactive transform tool.