Page MenuHome

Possible MAYOR bug in Blender-2.80-d966c2f0c2ad-win64 ( downloaded 25-4-2019 )
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Graphics card: NVidia

Blender Version Blender-2.80-d966c2f0c2ad-win64 ( downloaded 25-4-2019 )
Broken:
Worked:

Short description of error Loss of all personal files

Exact steps for others to reproduce the error

In DUTCH:

Er zit waarschijnlijk een GROTE bug in Blender 2.8.

Na echt heel lang geduld hebben besloot ik 25 april n's te kijken hoe Blender 2.8 er op mijn laptop uit zag.
Het programma gedownload, geïnstalleerd en geopend, heel mooi werk, Blender is werkelijk ongelofelijk aan het worden wat een mogelijkheden.

Na opstarten natuurlijk even de weg vinden, waar staat alles, daarbij geholpen door gebruikers op Youtube.
( ik zou zeggen zet alle informatie over Blender 2.8 op een apart kanaal op Youtube, de uitleg van iemand die je het ziet voordoen werkt honderd keer sneller dan Wiki's of Manuals, maar dat is een verhaal niet voor nu )

Ik vind Preferences onder Edit en vink wat Addons aan, dan kom ik erachter dat ik sommige ook nog aan moet zetten in het meest rechtse vak( is dat überhaupt nodig ? ).

Ik laad een met Blender 7.9b gemaakte tekening en rommel daar wat mee.
Na daarvan wijzer geworden te zijn sluit ik Blender 2.8 af en besluit een link te maken in het Startmenu van mijn Windows 10 installatie.

Op dat moment staat daar al een link naar Blender 2.7b.
Die vink ik aan om Blender 2.9b op te starten en daar wat te doen, ik weet daar de weg.
Na dat gedaan te hebben sluit ik 2.7b af en ga terug naar 2.8, nog wat koekeloeren ( prachtig oudhollands woordgebruik ).
Maar, de link in mijn Startmenu werkt niet, Blender 2.8 flitst even op met een vage bovenbalk en een verder grijs scherm en is meteen weer weg.

Nog een paar keer proberen, nee, wil niet starten.
De .exe opgezocht en die direct geprobeerd, helaas.

MAAR NU KOMT HET. . .

Blender 2.8 voorlopig latend voor wat het was, terug naar andere dingen doen op mijn laptop.
Ik merk meteen al dat mijn zelfgemaakt icoontjes voor mijn mappen weg zijn, huh ?
Maar erger, mappen openend blijkt er niets meer in te staan !
Al mijn mappen met van alles en nog wat, zijn allemaal leeg !
De mappen zelf staan er nog wel, met hun naam, maar de inhoud ( ook de interne mapstructuur ) alles is weg.

Foto's, video's, teksten, Blenderfiles, Sketchupfiles...alles alles alles weg.

WTF ?

Godzijdank wist ik van het bestaan van Recuva ( Piriform ) en die heeft het meeste terug kunnen vinden.
Meteen op een externe harde schijf gezet, dit overkomt me niet nog een keer.

Goed, ik was safe, maar wilde wel weten waardoor dat kwam natuurlijk.
Geen crash, maar enkel en heel raar alleen maar al mijn opgeslagen data weg, de mappen zelf nog aanwezig maar leeg (-gehaald ).
Was dit een virus ?
Windows 10 kwam bij het overzetten van de door Recuva teruggevonden data wel een virus tegen ( een Trojan Horse ) maar had die gevonden en verwijderd.

Het leek toch echt wel door Blender 2.8 te komen, of misschien omdat ik 2.7b er nog op had staan ofzo.

Okee, een installatie met een foutje misschien, Blender 2.8 opnieuw gedownload en geïnstallleerd.

Opnieuw opstarten via de link in het Startmenu, joepie Blender 2.8 start weer op.
Maar ik merk meteen al dat deze nieuwe installatie de vorige niet volledig overschreven heeft, de veranderingen die ik gemaakt had zijn er nu ook.

Hmmm, ik vertrouw het niet helemaal, had ik eerst de eerst geïnstalleerde versie 2.8 moeten de-installeren ?
Vaak genoeg meegemaakt met andere programma's dat er toch dingen achterblijven en opnieuw meegenomen worden bij een nieuwe installatie.

Ik sluit Blender 2.8 af.
En wat blijkt...wederom zijn mijn mappen leeg, alles wat ik had kunnen terugzetten met dank aan Recuva, het was opnieuw weg.
Geen nood, ik heb alles nu op een externe harde schijf, het is niet weg.

Nou zakt mijn broek af... dit komt door Blender 2.8, kan niet anders.

Ik Google of dit een bekend probleem is maar kan geen probleem zoals dit vinden.
Misschien ben ik de enige en komt het doordat ik de dingen zo gedaan heb als ik gedaan heb.
Maar hoe dan ook, ik weet dat Blender 2.8 nog niet klaar is, er word nog aan gewerkt.

Dus als steeds enthousiaster wordende fan van Blender besluit mijn bevindingen te melden zodat het bekeken kan worden en er misschien iets aan gedaan kan worden.
Als mij dit overkomen kan kan het anderen ook overkomen.

Of het Blender 2.8 is weet ik niet, ik ben maar een leek, het kan ook Windows 10 zijn of een combinatie misschien.

Een laatste rare bijkomstigheid, na opstarten van mijn laptop staat ineens Google Chrome op mijn bureaublad.
Maar dat kan toeval zijn ?
Hoewel, hoe komt Googls Chrome erbij zich te installeren en een shortcut op mijn bureaublad te plaatsen ?

Rare dag vandaag, gelukkig ben ik niet al mijn data kwijt.

Hierbij geef ik mijn bevindingen door, ik hoop dat het Blender team er wat mee kan.

Succes met alle ontwikkelingen, Blender is een prachtprogramma aan het worden met een gouden toekomst.

Met vriendelijke groet,

Tom Heerema
rebello@live.nl

p.s. als dit inderdaad een BUG blijkt te zijn en het kan verholpen worden zou ik dat graag weten.
Gewoon om te weten dat ik ook nog iets aan Blender heb bij kunnen dragen.
Met dank.

Details

Type
Bug

Event Timeline

Where did you download your version of 2.8 from?

What you described sounds unrelated to Blender and more like your computer has been infected with malware.

Downloaded from https://www.blender.org/download/

Malware may be possible, but unlikely because the same thing happened exactly alike a second time when installing Blender again.
This means to me it is anyhow related to the Blender install.
Not any other thing on my laptop has changed as far as I know.
So malware only affecting things ( removal of personal files ) when installing Blender seams to me very unlikely.
But then again, someone might have made malware to operate when Installing Blender 2.8.
Maybe Autodesk ?

Thanks for taking an interest.

Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.

This doesn't really make sense. It's theoretically possible that Blender would cause this kind of issue, but it seems very unlikely. There is some factor here we are not understanding, but I can't think of much we can do on our side to figure that out.

I'm guessing the link to Blender installation is coincidental or that installation is triggering some issue in another software.

I'm afraid there is no much we can practically do here unless you can figure out more about what is going on.

Brecht Van Lommel (brecht) claimed this task.

Closing due to lack of information to investigate further, we can reopen the report if you can find more details to go on.