Page MenuHome

Eevee: Refractive materials appear with checkerboard pattern in Render Result (Intel graphics only)
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.17763 64 Bits
Graphics card: Intel(R) HD Graphics 4400 Intel 4.3.0 - Build 20.19.15.5063

Blender Version
Broken: version: 2.80 (sub 59), branch: master, commit date: 2019-04-26 06:00, hash: rB513b71c89ad0
Worked: (optional)

Short description of error
Objects with refractive materials appear with a checkerboard pattern in the final Render Result. A saved PNG file is actually transparent in these places. Both the viewport preview and the Cycles render look correct. This issue only appears on my notebook with Intel graphics. The same scene renders fine on a PC with an Nvidia card.

Exact steps for others to reproduce the error

  1. Create a new material on the default cube
  2. Set Transmission on the Principled BSDF to 0.85
  3. In the material settings, enable "Screen Space Refraction"
  4. In the render settings, enable "Screen Space Reflections" and "Refraction"
  5. Render the scene

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Thu, Jun 6, 12:21 PM

Does this still happen with the latest drivers from here: https://downloadcenter.intel.com/product/81496/Intel-HD-Graphics-4400 ?

It looks like this has been fixed somehow in the current build (8b2b79c2108b), even before I updated the driver. Also looking good after driver update, so I guess this issue can be closed. I'll report here if I notice it again.

Sebastian Parborg (zeddb) closed this task as Resolved.Thu, Jun 6, 3:23 PM
Sebastian Parborg (zeddb) claimed this task.

Ok, thanks for checking!